文华指标公式--宝塔线


宝塔线(文华指标公式)

C1:=REF(CLOSE,1);
C2:=REF(CLOSE,2);
C3:=REF(CLOSE,3);
C4:=REF(CLOSE,4);
CMAX:=HHV(CLOSE,4);
CMIN:=LLV(CLOSE,4);
STICKLINE(CLOSE=CMAX && (C1>=C2 || C1>=C3) || C1=CMAX && (C2=CMIN || C3=CMIN)
&& CLOSE>=C2 ||C2=CMAX && C3=CMIN && CLOSE>=C1 || C3=CMAX && CLOSE>=C1&& CLOSE>=C2,C1,CLOSE,COLORRED,1);
STICKLINE(CLOSE=CMAX && C1=CMIN,C2,CLOSE,COLORRED,1);
STICKLINE(CLOSE=CMIN && (C1<C2 || C1<C3) || C1=CMIN && (C2=CMAX || C3=CMAX) && CLOSE<C2 ||
C2=CMIN && C3=CMAX && CLOSE<C1 || C3=CMIN && CLOSE<C1 && CLOSE<C2,C1,CLOSE,COLORGREEN,0);
STICKLINE(C1=CMAX && CLOSE=CMIN,C2,CLOSE,COLORGREEN,0);
STICKLINE(C1=CMIN && CLOSE>=C2 || (C2=CMIN && C1<=C3 ||
C3=CMIN && C1<=C2) && C2<C4 && CLOSE>=C1,C1,C2,COLORGREEN,0);
STICKLINE(C1=CMAX && CLOSE<C2 || (C2=CMAX && C1>C3 ||
C3=CMAX && C1>C2) && C2>=C4 && CLOSE<C1,C1,C2,COLORRED,1);