文华跨周期交易模型


跨周期交易

程序化交易模型源码:
//在一分钟K线下加载交易模型
//指标名称为YYMA
A:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
B:=MA(CLOSE,26);
BK1:=A>B && ISUP && (C-O)>=(H-L-C+O) && C>A;
SP1:=A>B && ISDOWN && (O-C)>=(H-L-O+C) && C<A;
SK1:=A<B && ISDOWN && (O-C)>=(H-L-O+C) && C<A;
BP1:=A<B && ISUP && (C-O)>=(H-L-C+O) && C>A;

//模型
A:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
B:=MA(CLOSE,26);
#IMPORT [ ,DAY,YYMA] AS VARYY
BK1:=VARYY.BK1;
SP1:=VARYY.SP1;
SK1:=VARYY.SK1;
BP1:=VARYY.BP1;
BK1 && TIME<1457,BK;
SP1 || TIME>=1457,SP;
SK1 && TIME<1457,SK;
BP1 || TIME>=1457,BP;

点击复制上述代码粘贴到到公式管理器