文华均线与MACD结合交易模型源码


文华均线与MACD结合交易模型源码:

SHORT:=12;//参数
LONG:=26;//参数
M:=9;//参数
A:=MA(CLOSE,20);
MA1:=MA(CLOSE,1);
VAR11:=(2*CLOSE+OPEN+HIGH+LOW)/5;
M8:=SUM(VAR11*VOL,8)/SUM(VOL,8);
SH:=LLV(M8, 8)+MA1*0.118;
DIFF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=MA(DIFF,M);
MM:=MA1-A;
MD:=DIFF-DEA;
QF1:=IFELSE(REF(MM,2)<REF(MM,1)&&REF(MM,1)<MM,1,IFELSE(REF(MM,2)>REF(MM,1)&&REF(MM,1)>MM,2,0));
MF1:=IFELSE(REF(MD,2)<REF(MD,1)&&REF(MD,1)<MD,1,IFELSE(REF(MD,2)>REF(MD,1)&&REF(MD,1)>MD,2,0));
QF1=1&&MF1=1,BK;
QF1=2&&MF1=2,SK;
HIGH>=BKPRICE+13,SP;
LOW<=BKPRICE-8,SP;
LOW<=SKPRICE-13,BP;
HIGH>=SKPRICE+8,BP;
AUTOFILTER;//用于MYTRADE的话,后两行去掉
AUTOMERGE;

===========================================

源码解析:

SHORT赋值:12
参数LONG赋值:26
参数M赋值:9
参数A赋值:收盘价的20日简单移动平均
MA1赋值:收盘价的1日简单移动平均
VAR11赋值:(2*收盘价+开盘价+最高价+最低价)/5
M8赋值:VAR11*成交量(手)的8日累和/成交量(手)的8日累和
SH赋值:8日内M8的最低值+MA1*0.118
DIFF赋值:收盘价的SHORT日指数移动平均-收盘价的LONG日指数移动平均
DEA赋值:DIFF的M日简单移动平均
MM赋值:MA1-A
MD赋值:DIFF-DEA
QF1赋值:IFELSE(2日前的MM<昨日MM并且昨日MM<MM,1,IFELSE(2日前的MM>昨日MM并且昨日MM>MM,2,0))
MF1赋值:IFELSE(2日前的MD<昨日MD并且昨日MD<MD,1,IFELSE(2日前的MD>昨日MD并且昨日MD>MD,2,0))
QF1=1并且MF1=1,BK
QF1=2并且MF1=2,SK
最高价>=BKPRICE+13,SP
最低价<=BKPRICE-8,SP
最低价<=SKPRICE-13,BP
最高价>=SKPRICE+8,BP
AUTOFILTER
//用于MYTRADE的话,后两行去掉AUTOMERGE