同花顺涨停踏浪指标公式


  VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

  VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);

  VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

  VAR1D:=SMA(VAR1C,4,1);

  VAR1E:=SMA(VAR1D,3,1);

  VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

  VARE:=REF(LOW,1)*0.9;

  VARF:=LOW*0.9;

  VAR10:=(VARF*VOL+VARE*(SHGZG-VOL))/SHGZG;

  VAR11:=EMA(VAR10,30);

  VAR12:=CLOSE-REF(CLOSE,1);

  VAR13:=MAX(VAR12,0);

  VAR14:=ABS(VAR12);

  VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;

  VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;

  VAR17:=BARSCOUNT(CLOSE);

  VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;

  VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;

  VAR20:=(VAR18《=25 AND VAR19《-95 AND VAR1F》20 AND VAR1B《-30 AND VAR1E《30 AND VAR11-CLOSE》=-0.25 AND VAR15《22 AND VAR16《28 AND VAR17》50);

  FILLRGN(0,50,VAR20》0,RGB(17,135,135));

  LC := REF(CLOSE,1);

  标尺:SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100,colorgreen,LINETHICK1;

  VAR2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  VAR3:=SMA(VAR2,3,1);

  VAR4:=SMA(VAR3,3,1);

  VAR5:=SMA(VAR4,2,1);

  浪:3*VAR4-2*VAR5,LINETHICK1,colormagenta;

  波:VAR4,LINETHICK1,colorred;

  段:VAR5,LINETHICK1,coloryellow;

  Y:-2,colorblue,LINETHICK2;

  B:99,coloryellow,DOTLINE,LINETHICK1;

  T: 81,colorred,DOTLINE,LINETHICK1;

  X: 15,colorgreen,DOTLINE,LINETHICK1;

  VAR6:=CROSS(VAR3,波) AND 波《25;

  VAR61:=CROSS(波,段) AND 波《50;

  STICKLINE(VAR6,0,波+6,1,1),COLORFF00FF,LINETHICK4;

  STICKLINE(VAR61,0,波+6,1,1),COLORFFFFFF,LINETHICK4;

  DRAWTEXT(FILTER(VAR61,7),段+2,‘-短线买入’),COLORFFFFFF;

  DRAWTEXT(VAR61 AND 波》段*1.1 AND 波《20 AND 段《20,段+5,‘-短线’),colorred;

  VAR7:=CROSS(波,段) AND 波《50;

  VAR8:=VAR7 AND VOL》=REF(VOL,1)*2 AND VOL》=REF(MA(VOL,5),1)*2;

  STICKLINE(VAR8,0,波+6,1,1),colorred,LINETHICK4;

  DRAWTEXT(VAR8 AND COUNT(VAR8,8)=1,波-10,‘-放量’),colorred;

  VARA:=CROSS(段,波) AND 段》=70;

  STICKLINE(VARA,波-6,100,1,1),coloryellow,LINETHICK4;

  Varw8:=CROSS(Var3,Var4) AND Var4》80 AND Var4》Var5;

  STICKLINE(Varw8 AND COUNT(Varw8,5)=1,Var4-5,100,1,1), linethick2,colorgreen;

  DRAWTEXT(VARA AND COUNT(VARA,8)=1,波+15,‘牛市震荡’), coloryellow;

  DRAWTEXT(VARA AND COUNT(VARA,8)=1,波+6,‘熊市抛股’), coloryellow;

  DRAWTEXT(FILTER(VAR20,10),60,‘百万导弹’),colorgreen;

  YY:0,colorred,LINETHICK1;

  HH:90,colorred,DOTLINE,LINETHICK1;