同花顺百顺顶底指标公式


  Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;

  Q3:=SMA(Q2, 9, 1);

  Q4:=SMA(Q3, 3, 1);

  长趋势:3*Q3-2*Q4,colorwhite,LINETHICK3;

  趋势线:EMA(Q3, 3),colorred,LINETHICK3;

  DRAWTEXT(CROSS(趋势线, 长趋势) AND REF(长趋势,1)》80, REF(长趋势,3), ‘顶’),colorred,LINETHICK5;

  逢低买: DRAWTEXT(REF(CROSS(趋势线,长趋势),82) AND 趋势线》1.3*长趋势,长趋势,‘逢低买’),LINETHICK1;

  买: DRAWTEXT(REF(CROSS(长趋势,趋势线),1) AND 长趋势》1.3*趋势线,趋势线,‘买’),colorred,LINETHICK1;

  VAR3:=PEAKBARS(3,15,1)《10;

  VAR5:=IF(VAR3=1,2,0);

  顶:= IF(VAR5=2,2,0);

  顶A:IF(顶》REF(顶,1),50,0),colorgreen;

  DRAWTEXT(顶A=50,45,‘快逃’),COLOR00FF00;

  金叉: CROSS(长趋势,趋势线);

  DRAWTEXT(金叉,趋势线,‘★’),colorred;

  VAR2:=TROUGHBARS(3,15,1)《10;

  VAR3:=PEAKBARS(3,15,1)《10;

  VAR4:=IF(VAR2=1,50,0);

  VAR5:=IF(VAR3=1,50,0);

  底部:=IF(VAR4=50,10,0);

  多头能量:0,colorwhite,LINETHICK2;

  买入:IF(底部=10 AND REF(底部,1)=10 AND REF(底部,2)=0,50,0),COLOR0000CC,LINETHICK2;

  买入延迟线:底部,LINETHICK1 ,COLOR00CCFF;