同花顺火山喷发指标公式


  Var1:=EMA(HHV(HIGH,500),21);

  Var2:=EMA(HHV(HIGH,250),21);

  Var3:=EMA(HHV(HIGH,90),21);

  Var4:=EMA(LLV(LOW,500),21);

  Var5:=EMA(LLV(LOW,250),21);

  Var6:=EMA(LLV(LOW,90),21);

  Var7:=EMA((Var4*0.96+Var5*0.96+Var6*0.96+Var1*0.558+Var2*0.558+Var3*0.558)/6,21);

  Var8:=EMA((Var4*1.25+Var5*1.23+Var6*1.2+Var1*0.55+Var2*0.55+Var3*0.65)/6,21);

  Var9:=EMA((Var4*1.3+Var5*1.3+Var6*1.3+Var1*0.68+Var2*0.68+Var3*0.68)/6,21);

  VarA:=EMA((Var7*3+Var8*2+Var9)/6*1.738,21);

  VarB:=REF(LOW,1);

  VarC:=SMA(ABS(LOW-VarB),3,1)/SMA(MAX(LOW-VarB,0),3,1)*100;

  VarD:=EMA(IF(CLOSE*1.35《=VarA,VarC*10,VarC/10),3);

  VarE:=LLV(LOW,30);

  VarF:=HHV(VarD,30);

  Var10:=IF(MA(CLOSE,58),1,0);

  寒冰谷: -EMA(IF(LOW《=VarE,(VarD+VarF*2)/2,0),3)/618*Var10;

  寒冰: STICKLINE(寒冰谷《0,0,寒冰谷,-4,1),STICK,linethick2,COLORFF0000;

  今量1: 寒冰谷;

  a1:IF(寒冰谷《0,今量1*6,0),STICK,linethick5, COLORFFFFFF;

  a2:IF(寒冰谷《0,今量1*0.8,0),STICK,linethick5, COLORFFFF00;

  a3:IF(寒冰谷《0,今量1*0.6,0),STICK,linethick5, COLORFF9933;

  a4:IF(寒冰谷《0,今量1*0.4,0) ,STICK,linethick5,COLORFF6633;

  a5:IF(寒冰谷《0,今量1*0.2,0) ,STICK,linethick5,COLORFF0000;

  Var1a:=(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*100-70;

  Var2a:=SMA(Var1a,9,1)+100;

  Var3a:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;

  Var4a:=SMA(Var3a,3,1);

  Var5a:=SMA(Var4a,3,1)+100;

  Var6a:=Var5a-Var2a;

  t1:=寒冰谷》REF(寒冰谷,1) AND REF(寒冰谷,1)《REF(寒冰谷,2);

  火焰山: EMA(IF(LOW《=VarE,(VarD+VarF*2)/2,0),3)/618*Var10;

  火焰: IF(火焰山》0,火焰山,0),STICK,linethick2, COLOR0000ff;

  今量: 火焰山;

  a1:IF(火焰山》0,今量*1.2,0),STICK,linethick5, COLOR0000ff;

  a2:IF(火焰山》0,今量*0.8,0),STICK,linethick5, COLOR0066ff;

  a3:IF(火焰山》0,今量*0.6,0),STICK,linethick5, COLOR0099ff;

  a4:IF(火焰山》0,今量*0.4,0) ,STICK,linethick5,COLOR00ccff;

  a5:IF(火焰山》0,今量*0.2,0) ,STICK,linethick5,COLOR00ffff;YKHYKHE