同花顺牛人传说指标公式


  VAR1:=PEAKBARS(2,13,1)《10;

  VAR2:=IF(VAR1=1,2,0);

  顶1:= IF(VAR2=2,1,0);

  顶B:IF(顶1》REF(顶1,1),78,100,0),colorgreen,linethick2;

  var3:=PEAKBARS(3,8,1)《10;

  var5:=IF(var3=1,2,0);

  顶:= IF(var5=2,1,0);

  顶A:IF(顶》REF(顶,1),78,100,0),coloryellow,linethick2;

  DRAWTEXT(顶A=5,4.5,‘↓’),coloryellow;

  VARC:=(ZIG(3,8)》REF(ZIG(3,8),1)) AND (REF(ZIG(3,8),1)《=REF(ZIG(3,8),2)) AND (REF(ZIG

  (3,8),2)《=REF(ZIG(3,8),3));

  STICKLINE((VARC=1),18,0,8,1),colormagenta;

  DRAWTEXT((VARC=1),8,‘+买’),colorwhite;

  LL:=EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);

  FILLRGN(LL,90,LL》90,RGB(0,255,0),RGB(255,0,0));

  FILLRGN(LL,10,LL《10,RGB(255,0,0),RGB(0,255,0));

  风险值:EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),LINETHICK2,colorcyan;

  预警:90,,LINETHICK;

  安全区:10,,LINETHICK;

  N1:=9;N2:=5;

  MTM:=C-REF(C,1);

  ZLGJ:100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1),colorwhite;

  MAZL:MA(ZLGJ,N2),coloryellow;

  VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

  VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);

  VAR3:=EMA(VAR2,10);

  VAR4:=LLV(LOW,33);

  VAR5:=EMA(IF(LOW《=VAR4,VAR3,0),3);

  主力进场:IF(VAR5》REF(VAR5,1),VAR5,0),colorred,NODRAW;

  STICKLINE(VAR5》REF(VAR5,1),0,VAR5,3,0 ),COLOR000055;

  STICKLINE(VAR5》REF(VAR5,1),0,VAR5,2.6,0 ),COLOR000077;

  STICKLINE(VAR5》REF(VAR5,1),0,VAR5,2.1,0 ),COLOR000099;

  STICKLINE(VAR5》REF(VAR5,1),0,VAR5,1.5,0 ),COLOR0000BB;

  STICKLINE(VAR5》REF(VAR5,1),0,VAR5,0.9,0 ),COLOR0000DD;

  STICKLINE(VAR5》REF(VAR5,1),0,VAR5,0.3,0 ),COLOR0000FF;

  Var3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

  Var4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

  Var5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

  Var6:=(Var3+Var4+Var5)/3;

  Var7:=EMA(Var6,5);

  指标: EMA(EMA(Var3,5),5)*3, COLORSTICK;

  Var8:=IF(Var6《=-20,10,0);

  Var9:=HHV(Var8,10);

  STICKLINE(Var8=10,20,10,5,0),COLOR6666FF;

  VarA:=IF(Var9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);

  K:EMA(Var7,5)*2, COLORff00ff;

  D:EMA(K,5), colorwhite;

  J:K*3-D*2, coloryellow;

  VarB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J》10;

  换手: VOL/CAPITAL*100,colorgreen;

  DRAWTEXT(VarA=20,15,‘底部’),linethick1,colorwhite;

  STICKLINE((VarA=20),0,10,5,0),colorwhite;

  VARC:=(ZIG(3,5)》REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)《=REF(ZIG(3,5),2))

  AND (REF(ZIG

  (3,5),2)《=REF(ZIG(3,5),3));

  VARD:=(ZIG(3,5)《REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)》=REF(ZIG(3,5),2))

  AND (REF(ZIG

  (3,5),2)》=REF(ZIG(3,5),3));

  STICKLINE((VARC=1),(-14),0,4,0),Color0000FF;

  DRAWTEXT((VARC=1),(-14),‘买’),Color0000FF;

  STICKLINE((VARD=1),14,0,4,0),Color00FF00;

  DRAWTEXT((VARD=1),18,‘卖’),Color00FF00;

  VarE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

  VarF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

  ((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  Var10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

  ((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  Var11:=VarF《REF(Var10,1) AND VOL》REF(VOL,1) AND CLOSE》REF(CLOSE,1);

  DRAWTEXT(Var11 AND COUNT(Var11,30)=1,15,‘大资金活动’),linethick1,COLORff00ff;

  STICKLINE(Var11 AND COUNT(Var11,30)=1,1,10,5,0),colorff00ff;

  Var12:=(HIGH+LOW+CLOSE)/3;

  Var13:=(Var12-MA(Var12,14))/(0.015*AVEDEV(Var12,14));

  Var14:=(Var12-MA(Var12,70))/(0.015*AVEDEV(Var12,70));

  Var15:=IF(Var13》=150 AND Var13《200 AND Var14》=150 AND Var14《200,10,0);

  Var16:=IF(Var13《=-150 AND Var13》-200 AND Var14《=-150 AND

  Var14》-200,-10,Var15);

  Var17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

  Var18:=100-ABS(Var17);

  Var19:=IF(Var18《90,Var18,100);

  Var1A:=IF(VarE》0,VarE,0);

  Var1B:=IF(Var14》=200 AND Var13》=150,15,IF(Var14《=-200 AND

  Var13《=-150,-15,Var16))+60;

  Var1C:=Var1A》48 AND Var1B》60 AND Var19《100;

  DRAWTEXT(Var1C AND COUNT(Var1C,30)=1,15,‘大笔出货’),linethick1,COLORffcc66;

  STICKLINE(Var1C AND COUNT(Var1C,30)=1,0,10,5,0),colorffcc66;