同花顺优化凤凰图主图+选股指标源码免费公式


  同花顺优化凤凰图主图+选股指标源码免费公式

  移动平均线呈大幅上升趋势;经过一段上升后,移动平均线开始走平;当股价由上而下跌破走平的移动平均线时便是卖出的信号。

  1为了验证一条移动平均线所显示信号的可靠性,可以多选用几条移动平均线,以便相互参照。在正常情况下,成交量相应减少,卖出的信号更明确。

  2先确定移动平均线正处于下降过程中,再确定股价自下而上突破移动平均线,股价突破移动平均线后马上回落,当跌回到移动平均线之下时便是卖出的信号。

  这一卖出信号应置于股价下跌后的反弹时考察,即股价下跌过程中回升至前一次下跌幅度的三分之一左右时马上又呈下跌趋势、跌破移动平均线时应卖出。

  若在行情下跌过程中多次出现这种卖出的信号,越早脱手越好或作短线对冲。

  XOPEN:=(REF(O,1)+REF(C,1))/2;

  XCLOSE:=CLOSE;

  XHIGH:=MAX(HIGH,XOPEN);

  XLOW:=MIN(LOW,XOPEN);

  VOLALITY:=MA(XHIGH-XLOW,5);

  凰线:MA(XCLOSE,13)+VOLALITY/2;

  凤线:MA(XCLOSE,13)-VOLALITY/2;

  BU:=CROSS(XCLOSE,凰线);

  SEL:=CROSS(凤线,XCLOSE);

  VAR1:=BARSLAST(BU);

  VAR2:=BARSLAST(SEL);

  DRAWICON(REF(VAR1,1)》VAR2 AND CROSS(C》凰线,0.5),XLOW*0.98,17);

  DRAWTEXT(REF(VAR1,1)》VAR2 AND VAR1=0,XLOW*0.95,‘买’),COLOR00FFFF;

  DRAWICON(REF(VAR2,1)》VAR1 AND VAR2=0,XHIGH,6);

  DRAWTEXT(REF(VAR2,1)》VAR1 AND VAR2=0,XHIGH*1.05,‘卖’),COLORFFFF00;

  STICKLINE(XCLOSE》XOPEN AND VAR1《VAR2,XCLOSE,XOPEN ,2.7,0 ),COLORFF00FF;

  STICKLINE(XCLOSE》XOPEN AND VAR1《VAR2,XHIGH,XCLOSE ,0,0 ),COLORFF00FF;

  STICKLINE(XCLOSE》XOPEN AND VAR1《VAR2,XOPEN,XLOW ,0,0 ),COLORFF00FF;

  STICKLINE(XCLOSE《=XOPEN AND VAR1《VAR2,XCLOSE,XOPEN ,2.7,0 ),COLORYELLOW;

  STICKLINE(XCLOSE《=XOPEN AND VAR1《VAR2,XHIGH,XOPEN ,0,0 ),COLORYELLOW;

  STICKLINE(XCLOSE《=XOPEN AND VAR1《VAR2,XCLOSE,XLOW ,0,0 ),COLORYELLOW;

  {

  选股公式:

  XOPEN:=(REF(O,1)+REF(C,1))/2;

  XCLOSE:=CLOSE;

  XHIGH:=MAX(HIGH,XOPEN);

  XLOW:=MIN(LOW,XOPEN);

  VOLALITY:=MA(XHIGH-XLOW,5);

  凰线:=MA(XCLOSE,13)+VOLALITY/2;

  凤线:=MA(XCLOSE,13)-VOLALITY/2;

  BU:=CROSS(XCLOSE,凰线);

  SEL:=CROSS(凤线,XCLOSE);

  VAR1:=BARSLAST(BU);

  VAR2:=BARSLAST(SEL);

  REF(VAR1,1)》VAR2 AND VAR1=0;

  }