同花顺短线决策红箭头向上买股、绿箭头向下卖股主图指标


  同花顺短线决策红箭头向上买股、绿箭头向下卖股主图指标

  VAR3:=LLV(HIGH,240);

  VAR4:=100*(CLOSE-VAR3)/VAR3;

  VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;

  VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;

  VAR7:=0;

  VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;

  VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;

  VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH》LOW+0.04,4,0);

  VAR11:=ZIG(3,6)》REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)《=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)《=REF(ZIG(3,6),3);

  VAR12:=ZIG(3,6)《REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)》=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)》=REF(ZIG(3,6),3);

  VAR13:=ZIG(3,22)》REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)《=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)《=REF(ZIG(3,22),3);

  VAR14:=ZIG(3,22)《REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)》=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)》=REF(ZIG(3,22),3);

  VAR15:=ZIG(3,51)》REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)《=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)《=REF(ZIG(3,51),3);

  VAR16:=ZIG(3,51)《REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)》=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)》=REF(ZIG(3,51),3);

  VAR17:=ZIG(3,72)》REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)《=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)《=REF(ZIG(3,72),3);

  VAR18:=ZIG(3,72)《REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)》=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)》=REF(ZIG(3,72),3);

  VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);

  买1:=VAR10;

  买2:=(VAR11+VAR13+VAR15+VAR17);

  卖1:=(VAR12+VAR14+VAR16+VAR18);

  B:IF(买1》0 OR 买2》0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;

  DRAWTEXT(买1》0 OR 买2》0,LOW*0.99,‘买’),COLORRED;

  S:IF(卖1》0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;

  DRAWTEXT(卖1》0,HIGH*1.02,‘卖’),COLORGREEN;

  DRAWICON((ZIG(3,5)》REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)《=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)《=REF(ZIG(3,5),3)),LOW*0.98,1) ;

  DRAWICON((ZIG(3,5)《REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)》=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)》=REF(ZIG(3,5),3)),HIGH*1.01,2);

  ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK;

  VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);

  K:=EMA(VAR7,5)*2, , COLORFF00FF;

  D:=EMA(K,5), , COLORWHITE;

  J:=K*3-D*2, ,COLORYELLOW;

  VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J》10;

  HS:=VOL/CAPITAL*100, , COLORGREEN;

  VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

  VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,‘机构进场’),LINETHICK1,COLORFF00FF;

  VAR1A:=IF(VARE》0,VARE,0);

  VAR1B:=IF(VAR14》=200 AND VAR13》=150,15,IF(VAR14《=-200 AND VAR13《=-150,-15,VAR16))+60;

  VAR1C:=VAR1A》48 AND VAR1B》60 AND VAR19《100;

  DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,‘大顶(底)’),COLORWHITE;

  N:=IF(BARSCOUNT(C)》=8,8,BARSCOUNT(C));

  AMOV:=VOL*(C+L+H)/3;

  MN:=SUM(AMOV,N)/SUM(VOL,N);

  NOTEXT1:IF(C》=MN,MN,DRAWNULL),LINETHICK3,COLORYELLOW;

  NOTEXT2:IF(C《MN,MN,DRAWNULL),LINETHICK3,COLORGRAY;

  MA30:=MA(C,30);

  压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;

  支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;