通达信MACD支撑压力指标公式


  DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIF,9);

  MACD:(DIF-DEA)*2,COLORGREEN;

  MACD1:EMA((DIF-DEA)*2,3)COLORFF20FF;

  M:=INTPART(3*20/5);

  A12:=REF(MACD,M)=HHV(MACD,2*M+1);

  B12:=FILTER(A12,M);

  C12:=BACKSET(B12,M+1);

  D12:=FILTER(C12,M);{高点}

  R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1);

  S112:=R112》REF(R112,1);

  M1:=INTPART(3*10/5);

  M2:=REF(MACD,M1)=HHV(MACD,2*M1+1);

  M3:=FILTER(M2,M1);

  M4:=BACKSET(M3,M1+1);

  M5:=FILTER(M4,M1);

  M6:=BACKSET(ISLASTBAR,BARSLAST(M5)+1);

  M7:=M6》REF(M6,1);

  趋势3:DRAWLINE(M5 ,MACD,M7,MACD,1),POINTDOT;

  M10:=INTPART(3*15/5);

  M20:=REF(MACD,M10)=HHV(MACD,2*M10+1);

  M30:=FILTER(M20,M10);

  M40:=BACKSET(M30,M10+1);

  M50:=FILTER(M40,M10);

  M60:=BACKSET(ISLASTBAR,BARSLAST(M50)+1);

  M70:=M60》REF(M60,1);

  趋势30:DRAWLINE(M50 ,MACD,M70,MACD,1),POINTDOT;

  M100:=INTPART(3*20/5);

  M200:=REF(MACD,M100)=HHV(MACD,2*M100+1);

  M300:=FILTER(M200,M100);

  M400:=BACKSET(M300,M100+1);

  M500:=FILTER(M400,M100);

  M600:=BACKSET(ISLASTBAR,BARSLAST(M500)+1);

  M700:=M600》REF(M600,1);

  趋势300:DRAWLINE(M500 ,MACD,M700,MACD,1),POINTDOT;

  M1M:=INTPART(3*30/5);

  M2M:=REF(MACD,M1M)=HHV(MACD,2*M1M+1);

  M3M:=FILTER(M2M,M1M);

  M4M:=BACKSET(M3M,M1M+1);

  M5M:=FILTER(M4M,M1M);

  M6M:=BACKSET(ISLASTBAR,BARSLAST(M5M)+1);

  M7M:=M6M》REF(M6M,1);

  趋势3M:DRAWLINE(M5M ,MACD,M7M,MACD,1),POINTDOT;

  A22:=REF(MACD,M)=LLV(MACD,2*M+1);

  B22:=FILTER(A22,M);

  C22:=BACKSET(B22,M+1);

  D22:=FILTER(C22,M);{低点}

  T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1);

  U112:=T112》REF(T112,1);

  底线:DRAWLINE(D22,MACD,U112,MACD,1),COLORCD7F32,POINTDOT;

  MB:=INTPART(3*10/5);

  A22A:=REF(MACD,MB)=LLV(MACD,2*MB+1);

  B22A:=FILTER(A22A,MB);

  C22A:=BACKSET(B22A,MB+1);

  D22A:=FILTER(C22A,MB);

  T112A:=BACKSET(ISLASTBAR,BARSLAST(D22A)+1);

  U112A:=T112A》REF(T112A,1);

  底线2:DRAWLINE(D22A,MACD,U112A,MACD,1),COLORCD7F32,POINTDOT;

  IF(CROSS(MACD,趋势3) AND 趋势3《REF(趋势3,6) ,0.1,-0.1);