通达信降龙贰式指标公式


  说明:出现“无缝买点”的时候最好结合其他短线指标配合更加准确,出现“交叉”和“无缝买点”的时候,基本就是最佳时机了。

  龙:=MA(C,2);

  天:=MA(REF(HHV(C,30),1),2);

  海:=MA(REF(LLV(C,30),1),2);

  潜龙出海:CROSS(龙,海) AND 天/海》110/100;

  DRAWTEXT(潜龙出海,1,‘龙出海’),COLORYELLOW;

  亢龙有悔:2-(CROSS(天,龙) AND 天/海》110/100);

  DRAWTEXT(亢龙有悔,1.5,‘龙潜水’),COLORBLUE;

  R:=RSI;

  MAR:=MA(R,3);

  F:=100*(C-REF(C,1))/REF(C,1);

  HHH:=EMA(R,25)+6,COLORBLUE;

  JIN:STICKLINE(REF(R,2)》REF(R,3) AND REF(R,2)》REF(R,1) AND R》REF(R,1)

  AND MAR》REF(MAR,1)+1 AND REF(MAR,2)-REF(MAR,1)》-1

  AND REF(R,1)《REF(MAR,1) AND REF(R,2)-REF(MAR,2)》-3

  AND REF(R,1)《38 AND R《HHH AND F《8,0.5,1,1,0),COLORBROWN;

  DRAWTEXT(JIN,1.5,‘RSI买点’),COLORBROWN;

  VOLUME:=VOL/1000000,VOLSTICK;

  MAVOL1:=MA(VOLUME,5)/1000000;

  MAVOL2:=MA(VOLUME,35)/1000000;

  MAVOL3:=MA(VOLUME,135)/1000000;

  地量:IF(CROSS(0.9,1/VOL*1000》0.01 AND “KDJ.J”《0),0.5,0),COLORYELLOW,LINETHICK2;

  DRAWTEXT(CROSS(0.9,1/VOL*1000》0.01 AND “KDJ.J”《0),0.2,‘地量’),COLORBROWN;

  天衣:=EMA((CLOSE-LLV(LOW,10))/(HHV(HIGH,25)-LLV(LOW,10))*4,4)*25;

  无逢:=SMA(天衣,2,1);

  无逢买点:CROSS(天衣,无逢)AND 无逢《15,COLORRED;{15可以调整}

  DRAWTEXT(无逢买点,0.5,‘无缝买点’),COLORRED;

  T:=IF((BARSCOUNT(C) 》 7),(100)*((MA(C,7))/(LLV(MA(C,7),7)) - 1),1);

  N:=IF((T 》 0.35),6,65);

  W:=((-((100)*(HHV(H,N) - C))/(HHV(HIGH,N) - LLV(L,N))));

  RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

  RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;

  J0:=(HIGH+LOW)/2;

  QJ:=EMA(J0,3);

  J1:=IF(CLOSE》QJ,VOL,0);

  J2:=IF(CLOSE《QJ,VOL,0);

  BB:=MA(SUM(J1-J2,22),3);

  累加:=21*BB+20*REF(BB,1)+19*REF(BB,2)+18*REF(BB,3)+17*REF(BB,4)

  +16*REF(BB,5)+15*REF(BB,6)+14*REF(BB,7)+13*REF(BB,8)+12*REF

  (BB,9)+11*REF(BB,10)+10*REF(BB,11)+9*REF(BB,12)+8*REF(BB,13)

  +7*REF(BB,14)+6*REF(BB,15)+5*REF(BB,16)+4*REF(BB,17)+3*REF

  (BB,18)+2*REF(BB,19)+REF(BB,20);

  WMA2:=累加/(21+1)/21*2;

  CC:=WMA2;

  VAR3:=(BB-CC);VAR4:=SMA(RV,3,1);

  VAR5:=SMA(VAR4,3,1);

  KK:=EMA(SMA(RG,3,1),2);

  DD:=SMA(KK,3,1);

  天张停:CROSS(W,-2) AND CROSS(VAR4,VAR5) AND CROSS(KK,DD),COLORMAGENTA;

  DRAWTEXT(天张停,0.5,‘天张停’),COLORMAGENTA;

  GJW1:=(HIGH+LOW+CLOSE)/3;

  GJW2:=(GJW1-MA(GJW1,14))/(0.015*AVEDEV(GJW1,14));

  CCI低位穿:=CROSS(GJW2,-100);

  RSI金:=CROSS(“RSI.RSI1”(6,2,2),20) OR CROSS(“RSI.RSI1”,“RSI.RSI2”);

  KDJ金:=CROSS(“KDJ.K”,“KDJ.D”) AND “KDJ.J”《30;

  KDJ二金:=SUM(CROSS(“KDJ.K”,“KDJ.D”)AND “KDJ.D”《23,15)》=2 AND CROSS(“KDJ.K”,“KDJ.D”) AND “KDJ.J”《30;

  MACD金:=CROSS(“MACD.DIF”,“MACD.DEA”) AND “MACD.DEA” 《0;

  MACD二金:=SUM(CROSS(“MACD.DIF”,“MACD.DEA”) AND “MACD.DEA”《0,15)》=2 AND CROSS(“MACD.DIF”,“MACD.DEA”) AND “MACD.DEA”《0;

  GJW3:=CCI低位穿+RSI金+KDJ金+KDJ二金+MACD金+MACD二金;

  GJW4:=IF(GJW3=2,IF(REF(GJW3,1)》=1,25,15),IF(GJW3=1,IF(REF(GJW3,1)=2,25,0),0));

  穿叉:IF(GJW3》=3,30,GJW4)/10,COLORYELLOW,LINETHICK2;

  量:=VOL,VOLSTICK;

  MA5:=MA(V,5),LINETHICK2;

  MA35:=MA(V,35),LINETHICK2;

  N1:=(C-REF(C,1))/C;

  缩量:IF(MA35》1.8*MA5 AND V《MA(V,5) AND N1》-0.03 AND N1《0.03 AND MA(V,35)《MA(V,135) ,1,0);

  简:=EMA(CLOSE,12)-EMA(CLOSE,29);

  单:=EMA(简,9);

  实:=(简-单)*2;

  用:=IF(实》REF(实,1) AND 实《0,8,0);

  选:=MA((LOW+HIGH+CLOSE)/3,5),LINETHICK0,COLOR4080FF;

  股:=4*SMA((CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100,5,1),3.2,1);

  公:=REF(CLOSE,1);

  式:=SMA(MAX(CLOSE-公,0),6,1)/SMA(ABS(CLOSE-公),6,1)*100;

  入:CROSS(式,25);

  买:IF(CROSS(C,选) AND 用 AND REF(“KDJ.J”,1)《0 AND “KDJ.J”》0,0.8,0);

  进:IF(CROSS(C,选) AND 用 AND CROSS(股,8),0.6,0);

  LAST((H-L)/REF(C,1)《0.1,20,0) AND VOL》REF(VOL,1)*2 AND C》REF(C,1)*1.03

  AND “DMI.PDI”》“DMI.MDI” AND CROSS(“DMI.ADX”,“DMI.ADXR”)

  AND“DMI.ADXR”》“DMI.MDI” AND “DMI.PDI”》“DMI.ADX” AND“KDJ.D”》REF(“KDJ.D”,1);

  FILTER((CROSS((EMA(CLOSE,2)-EMA(CLOSE,10)),

  EMA((EMA(CLOSE,2)-EMA(CLOSE,10)),2))

  AND EMA((EMA(CLOSE,2)-EMA(CLOSE,10)),2)

  《0 AND CROSS(C,MA(C,20))),90);