同花顺借花敬佛主图指标公式


  天线:MA(REF(HHV(CLOSE,30),1),2),LINETHICK2,COLOR80E9FF;

  地线:MA(REF(LLV(CLOSE,30),1),2),LINETHICK2,COLOR669900;

  SD:=HHV(HIGH,13)=HIGH AND HIGH》REF(HIGH,1);

  SD1:=FILTER(SD,12);

  SF:=LLV(LOW,13)=LOW AND LOW《REF(LOW,1);

  SF1:=FILTER(SF,12);

  TSS1:=BARSLAST(SD1);

  箱顶:REF(HIGH,TSS1),LINETHICK0,colorred;

  TSS2:=BARSLAST(SF1);

  箱底:REF(LOW,TSS2),LINETHICK0,colorgreen;

  STICKLINE(OPEN》=CLOSE,HIGH,LOW,0.5 ,0 ),COLOR00FF00;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR005500;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR006600;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR007700;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR009900;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00BB00;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00DD00;

  STICKLINE(OPEN》=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;

  STICKLINE(CLOSE》OPEN,HIGH,LOW,0.5,0 ),COLOR0000FF;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,7,0) ,COLOR000055;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,6,0) ,COLOR000066;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,5,0) ,COLOR000077;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,4,0) ,COLOR000099;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,3,0) ,COLOR0000BB;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,2,0) ,COLOR0000DD;

  STICKLINE(CLOSE》OPEN,CLOSE,OPEN,1,0) ,COLOR0000FF;

  AA1:=MA(CLOSE,20);

  AA2:=(CLOSE 》 MA(CLOSE,5));

  AA3:=(MA(CLOSE,5) 》 MA(CLOSE,10));

  AA4:=(CLOSE 》 MA(CLOSE,10));

  AA5:=(MA(CLOSE,5) 》 MA(CLOSE,20));

  AA6:=(CLOSE 》 MA(CLOSE,20));

  AA7:=REF(AA1,1);

  AA8:=(AA1 》 AA7);

  AAX:=(((((IF(AA2,10,(0 - 10)) + IF(AA3,10,(0 - 10))) + IF(AA4,10,(0 - 10))) + IF(AA5,10,(0 - 10))) + IF(AA6,10,(0 - 10))) + IF(AA8,10,(0 - 10)));

  DSLX:=(CLOSE / INDEXC);

  DSLX1:=MA(DSLX,5);

  DSLX2:=MA(DSLX,10);

  V1:=MA(VOL,5);

  V2:=MA(VOL,10);

  MA20:=MA(C,20);

  MA40:=MA(C,40);

  MA60:=MA(C,60);

  BIAS:=(C-MA20)/MA20*100;

  SHOPEN:=OPEN;

  SHHIGH:=HIGH;

  SHLOW:=LOW;

  SHCLOSE:=CLOSE;

  SHAMOUNT:=AMOUNT;

  SHVOL:=VOL;

  J12:=(HIGH - ((HIGH - LOW) / 3));

  J23:=(LOW + ((HIGH - LOW) / 3));

  T1:=(((IF((CLOSE = OPEN),1,0) + IF((CLOSE 》= J12),1,0)) + IF((CLOSE 《= J23),1,0)) 》 1);

  T2:=((((CLOSE 》 J23) AND (CLOSE 《 J12)) AND (OPEN 》 J23)) AND (OPEN 《 J12));

  T3:=((CLOSE 》= J12) AND (OPEN 《= J23));

  T4:=(((OPEN 《= J12) AND (OPEN 》= J23)) AND (CLOSE 》 J12));

  T5:=(((OPEN 《= J23) AND (CLOSE 《= J12)) AND (CLOSE 》= J23));

  T6:=((CLOSE 《= J23) AND (OPEN 》= J12));

  T7:=(((OPEN 《= J12) AND (OPEN 》= J23)) AND (CLOSE 《 J23));

  T8:=(((OPEN 》= J12) AND (CLOSE 《= J12)) AND (CLOSE 》= J23));

  T9:=(((SHAMOUNT / SHVOL) / 100) 》 REF(HIGH,1));

  T10:=(((SHAMOUNT / SHVOL) / 100) 《 REF(LOW,1));

  GP:=‘ ’;

  IF ((O》C AND OPEN》MA(C,5) AND OPEN》MA(C,10) AND O》MA(C,20) AND CLOSE《MA(C,5) AND CLOSE《MA(C,10) AND CLOSE《MA(C,20)) OR (O《C AND OPEN《MA(C,5) AND OPEN《MA(C,10) AND O《MA(C,20) AND CLOSE》MA(C,5) AND CLOSE》MA(C,10) AND CLOSE》MA(C,20))) THEN GP:=GP+‘ 断头铡刀(出水芙蓉) -一根大阴(阳)线切断了三根均线 如果改变了其后均线的排列为空头(多头)排列 后势看空(多) 。’;

  LC:=REF(CLOSE,1);

  RSI1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;

  SELL1:=FILTER((CROSS(RSI1,88)),7);

  SELL2:=(CROSS(88,RSI1));

  KDJ:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K:=SMA(KDJ,3,1);

  D:=SMA(K,3,1);

  J:=3*K-2*D;

  TYP:= (HIGH + LOW + CLOSE)/3;

  CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

  DRAWTEXT(SELL1,HIGH*1.02,‘预警→’),COLORCC33CC,ALIGN2,VALIGN2;

  DRAWTEXT(SELL2,HIGH*1.02,‘▼’),COLORFFCC33,ALIGN1;

  DRAWTEXT(SELL2 AND (K》80 OR CCI》160),HIGH*1.04,‘▼’),COLORCC6633,ALIGN1;

  DRAWTEXT(SELL2 AND K》80 AND CCI》160,HIGH*1.06,‘▼’),COLORFF3300,ALIGN1;

  VB1:=AMOUNT/V;

  VB2:=L《VB1*0.9;

  VB3:=(C-REF(C,1))/REF(C,1)*100》1.2;

  VB4:=L《MA(C,5)*0.921;

  VB5:=V《MA(V,5)*1.5;

  VB6:=VB2 AND VB3 AND VB4 AND VB5;

  VB7:=EMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,34)-LLV(LOW,27))*4,4)*25;

  VB8:=IF((VB7《10),80,100);

  VB9:=IF(K《20,10,0);

  VB10:=LLV(J,2)=LLV(J,8);

  VB11:=IF(CROSS(J,REF(J+0.01,1)) AND VB10 AND J《20,30,0);

  DRAWTEXT(VB11 AND VB8=100 AND VB9=10,LOW*0.99,‘超跌’),COLOR8000FF;

  VB12:=C-REF(C,1);

  VB13:=100*EMA(EMA(VB12,6),6)/EMA(EMA(ABS(VB12),6),6);

  VB14:=IF(LLV(VB13,2)=LLV(VB13,7) AND COUNT(VB13《0,2) AND CROSS(VB13,MA(VB13,2)),1,0);

  VB15:=FILTER((VB14=1 OR VB6),7);

  VB16:=FILTER(VB6,5);

  VB17:=FILTER(VB14=1,5);

  DRAWTEXT(VB17,LOW*0.97,‘短线’),COLOR66CCFF;

  DRAWTEXT(VB16,LOW*0.98,‘考虑介入→’),COLOR336699,ALIGN2;

  止损:=(LC*1.0035*97+0.2)/99.65;

  VC:=(HIGH+LOW+OPEN+2*CLOSE)/5;

  明日阻力:=2*VC-LOW;

  明日支撑:=2*VC-HIGH;

  明日突破:=VC+(HIGH-LOW);

  明日反转:=VC-(HIGH-LOW);

  今日阻力:=REF(明日阻力 , 1);

  今日支撑:=REF(明日支撑 , 1);