飞狐群龙有首主图指标公式


  a1:=EMA((EMA(CLOSE,1)+EMA(CLOSE,3)+EMA(CLOSE,5))/3,3);

  a2:=EMA((EMA(CLOSE,3)+EMA(CLOSE,5)+EMA( CLOSE,7))/3,3);

  a3:=EMA((EMA(CLOSE,5)+EMA(CLOSE,7)+EMA( CLOSE,9))/3,3);

  a4:=EMA((EMA(CLOSE,7)+EMA(CLOSE,9)+EMA( CLOSE,11))/3,3);

  a5:=EMA((EMA(CLOSE,9)+EMA(CLOSE,11)+EMA( CLOSE,13))/3,3);

  a6:=EMA((EMA(CLOSE,11)+EMA(CLOSE,13)+EMA( CLOSE,15))/3,3);

  a7:=EMA((EMA(CLOSE,13)+EMA(CLOSE,15)+EMA( CLOSE,17))/3,3);

  a8:=EMA((EMA(CLOSE,15)+EMA(CLOSE,17)+EMA( CLOSE,19))/3,3);

  a9:=EMA((EMA(CLOSE,17)+EMA(CLOSE,19)+EMA( CLOSE,21))/3,3);

  a10:=EMA((EMA(CLOSE,19)+EMA(CLOSE,21)+EMA( CLOSE,23))/3,3);

  a11:=EMA((EMA(CLOSE,21)+EMA(CLOSE,23)+EMA( CLOSE,25))/3,3);

  A:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),LINETHICK0;

  多空:A,LINETHICK0;

  {hz2004716}

  a15:=a-(a1-a*0.997),colorFF1010;

  a16:=a-(a2-a),colorff2010;

  a17:=a-(a3-a),colorff3010;

  a18:=a-(a4-a),colorff4010;

  a19:=a-(a5-a),colorff5010;

  a20:=a-(a6-a),colorff6010;

  a21:=a-(a7-a),colorff7010;

  a22:=a-(a8-a),colorff8010;

  a23:=a-(a9-a),colorff9010;

  a24:=a-(a10-a),colorffc010;

  a25:=a-(a11-a*0.997),colorffe010;{LINEDOT;}

  FILLRGN(A9》A,A9,A),color436873;

  FILLRGN(A9《A,A9,A),color436873;

  FILLRGN(A23《A,A,A23),color4D635A;

  FILLRGN(A23》A,A,A23),color4D635A;

  PARTLINE(1,a15),colorFF1010;PARTLINE(1,a16),colorFF2010;

  PARTLINE(1,a17),colorFF3010;PARTLINE(1,a18),colorFF4010;

  PARTLINE(1,a19),colorFF5010;PARTLINE(1,a20),colorFF6010;

  PARTLINE(1,a21),colorFF7010;PARTLINE(1,a22),colorFF8010;

  PARTLINE(1,a23),colorFF9010;PARTLINE(1,a24),colorFFc010;

  PARTLINE(1,a25),colorFFe010;{LINEDOT;}

  PARTLINE(1,a1),color1010FF;PARTLINE(1,a2),color1020FF;

  PARTLINE(1,a3),color1030FF;PARTLINE(1,a4),color1040FF;

  PARTLINE(1,a5),color1050FF;PARTLINE(1,a6),color1060FF;

  PARTLINE(1,a7),color1070FF;PARTLINE(1,a8),color1080FF;

  PARTLINE(1,a9),color1090FF;PARTLINE(1,a10),color10c0FF;

  PARTLINE(1,a11),color10e0FF;{LINEDOT;}

  STICKLINE(OPEN》=CLOSE ,OPEN,CLOSE,9,0 ),COLORaaaaaa;

  STICKLINE(OPEN》=CLOSE ,OPEN,CLOSE,6,0 ),COLORbbbbbb;

  STICKLINE(OPEN》=CLOSE ,OPEN,CLOSE,2.4,0 ),COLORcccccc;

  STICKLINE(OPEN》=CLOSE ,OPEN,CLOSE,1.1,0 ),COLORdddddd;

  STICKLINE(CLOSE》OPEN,OPEN,CLOSE,9,0 ),COLOr6666cc;

  STICKLINE(CLOSE》OPEN,OPEN,CLOSE,6 ,0 ),COLOR7777dd;

  STICKLINE(CLOSE》OPEN,OPEN,CLOSE,2.4 ,0 ),COLOR8888ee;

  STICKLINE(CLOSE》OPEN,OPEN,CLOSE,1.1 ,0 ),COLOR9999ff;

  STICKLINE(CLOSE》OPEN,OPEN,LOW,0.5,0 ),COLOR1199ff;

  STICKLINE(CLOSE》OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR1199ff;

  STICKLINE(OPEN》=CLOSE,CLOSE,LOW,0.5 ,0 ),COLORcccccc;

  STICKLINE(OPEN》=CLOSE,OPEN,HIGH,0.5 ,0 ),COLORcccccc;

  DRAWICON(a《REF(a,1),a,‘s28’);

  DRAWICON(a》REF(a,1),a,‘s31’);

  A:=SYSPARAM(1)=BARPOS;

  x:IF(a》0,DATE,0),linethick0;

  mm:=BARSLAST(DATE=x);

  hh:HHV(HIGH,mm+1),color0000ff,linethick2;

  ll:LLV(LOW,mm+1),color00ff33,linethick2;

  mid:((hh+ll)/2),linethick2;

  ((hh-ll)/6+ll),color00ff66;

  (ll+(hh-ll)/6+(hh-ll)/6),color00ff99;

  (hh-(hh-ll)/6),color0033ff;

  (hh-(hh-ll)/6-(hh-ll)/6),color0099ff;