大智慧满仓操作主图指标公式


  N:=10;

  M:=250;

  MA5:MA(CLOSE,5),color000000;

  MA21:=EMA(CLOSE,21);

  风险线: MA(CLOSE,13),linethick3,COLORGREEN;

  止损线: MA(CLOSE,26),linethick0,Coloree00ee;

  牛熊线:ma(close,m),CIRCLEDOT,color999888;

  MID:MA(CLOSE,21),color000000,linethick0;

  UPPER:MID + 2*STD(C,20),COLOR000000;

  LOWER:MID - 2*STD(C,20),COLOR000000;

  STICKLINE((MA21 》 REF(MA21,1)),MA21,MA21,3,6),LINETHICK3,Color00FFFF;

  STICKLINE(C》=MID AND C》=O,C,O,5,0),COLORRED;

  STICKLINE(C》=MID AND C》=O,H,L,0,0),COLORRED;

  STICKLINE(C》=MID AND C《O,C,O,5,1),COLORRED;

  STICKLINE(C》=MID AND C《O,O,H,0,0),COLORRED;

  STICKLINE(C》=MID AND C《O,C,L,0,0),COLORRED;

  STICKLINE(C《MID AND C》O,C,O,5,1),COLORffff00;

  STICKLINE(C《MID AND C《=O,C,O,5,1),COLORffff00;

  STICKLINE(C《MID AND C《=O,H,L,0,1),COLORffff00;

  STICKLINE(C《MID AND C》O,C,H,0,1),COLORffff00;

  STICKLINE(C《MID AND C》O,O,L,0,1),COLORffff00;

  界:MA(CLOSE,26),COLOR000000,pointdot,linethick0;

  VAR1:=(100 - ((75 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));

  VAR2:=(100 - ((75 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));

  VAR3:=(100 - MA(((85 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));

  DRAWICON(CROSS(VAR2,MA(VAR3,5)),(LOW * 0.95),5),linethick3;

  DRAWICON(CROSS(MA(VAR3,5),VAR1),(HIGH * 1.05),5),linethick3;

  DRAWTEXT(CROSS(VAR2,MA(VAR3,5)),(LOW * 0.988),‘买’),coloryellow,linethick3;

  DRAWTEXT(CROSS(MA(VAR3,5),VAR1),(HIGH * 1.02),‘卖’),colorFFFF34,linethick3;

  STICKLINE(C》=界 AND C》=O,C,O,5,0),COLORRED;

  STICKLINE(C》=界 AND C》=O,H,L,0,0),COLORRED;

  STICKLINE(C》=界 AND C《O,C,O,5,1),COLORRED;

  STICKLINE(C》=界 AND C《O,O,H,0,0),COLORRED;

  STICKLINE(C》=界 AND C《O,C,L,0,0),COLORRED;

  STICKLINE(C《界 AND C》O,C,O,5,1),COLORffff00;

  STICKLINE(C《界 AND C《=O,C,O,5,1),COLORffff00;

  STICKLINE(C《界 AND C《=O,H,L,0,1),COLORffff00;

  STICKLINE(C《界 AND C》O,C,H,0,1),COLORffff00;

  STICKLINE(C《界 AND C》O,O,L,0,1),COLORffff00;

  P1:(HHV(HIGH,9)+LLV(LOW,9))/2,color000000;

  P2:(HHV(HIGH,26)+LLV(LOW,26))/2,color000000;

  P3:=ma(c,3);

  P4:=ma(P3,5);

  P5:=ma(P3,60);

  P6:=3*P5-2*P4;

  aa:=cross(P2,P6);

  bb:=cross(P1,P2);

  DRAWTEXT(bb,P2,‘好’),color00ff00;

  DRAWTEXT(aa,P2,‘好好’),color00ff00;

  aa1:=AMOUNT/vol;

  bb1:=l《aa1*0.9;

  cc1:=(c-ref(c,1))/ref(c,1)*100》1.2;

  dd1:=l《ma(c,5)*0.921;

  ee1:=vol《ma(v,5)*1.5;

  ff1:bb1 and cc1 and dd1 and ee1,linethick0;

  drawtext(ff1,l*0.99,‘老鼠仓’),color00ff00;

  stickline(ff1,h,l,0.5,0),color00ff00;

  stickline(ff1,o,c,6,1),linethick2,color00ff00;