通达信异形K线主图指标公式


  AZ1:=HHV(MA(C,3),10);

  AZ2:=HHV(MA(C,3),9);

  AZ3:=HHV(MA(C,3),8);

  AZ4:=HHV(MA(C,3),7);

  AZ5:=HHV(MA(C,3),6);

  AZ6:=HHV(MA(C,3),5);

  AZ7:=HHV(MA(C,3),4);

  AZ8:=HHV(MA(C,3),3);

  AZ9:=HHV(MA(C,3),2);

  BZ9:=LLV(MA(C,3),2);

  A:=WMA(C,3);

  B:=IF(AZ1=AZ2=AZ3=AZ4=AZ5=AZ6=AZ7=AZ8=AZ9,AZ9,BZ9);

  STICKLINE(A》=B,A,B,3,0),COLOR000099;

  STICKLINE(A》=B,A,B,2,0),COLOR0000BB;

  STICKLINE(A》=B,A,B,1,0),COLOR0000DD;

  STICKLINE(A》=B,A,B,0.05,0),COLOR0000FF;

  STICKLINE(A》B,A,H,0.00001,0),COLORRED;

  STICKLINE(A《=B,A,B,3,0),COLOR009900;

  STICKLINE(A《=B,A,B,2,0),COLOR00BB00;

  STICKLINE(A《=B,A,B,1,0),COLOR00CC00;

  STICKLINE(A《=B,A,B,0.05,0),COLOR00EE00;

  STICKLINE(A《B,A,L,0.00001,0),COLOR00FF00;

  A1:EMA(EMA(EMA(CLOSE,2),2),2),COLORFF00FF,LINETHICK1;

  A2:EMA(EMA(EMA(CLOSE,3),3),2),COLORFF00FF,LINETHICK1;

  A3:EMA(EMA(EMA(CLOSE,4),4),2),COLORFF00FF,LINETHICK1;

  A4:EMA(EMA(EMA(CLOSE,5),5),2),COLORFF00FF,LINETHICK1;

  A5:EMA(EMA(EMA(CLOSE,6),6),3),COLORFF00FF,LINETHICK1;

  A6:EMA(EMA(EMA(CLOSE,7),7),3),COLORFF00FF,LINETHICK1;

  A7:EMA(EMA(EMA(CLOSE,9),9),3),COLORFF00FF,LINETHICK1;

  B1:=BACKSET(A1《REF(A1,1),2);

  IF(B1,A1,DRAWNULL),COLOR33FF20,LINETHICK1;

  B2:=BACKSET(A2《REF(A2,1),2);

  IF(B2,A2,DRAWNULL),COLOR33FF20,LINETHICK1;

  B3:=BACKSET(A3《REF(A3,1),2);

  IF(B3,A3,DRAWNULL),COLOR33FF20,LINETHICK1;

  B4:=BACKSET(A4《REF(A4,1),2);

  IF(B4,A4,DRAWNULL),COLOR33FF20,LINETHICK1;

  B5:=BACKSET(A5《REF(A5,1),2);

  IF(B5,A5,DRAWNULL),COLOR33FF20,LINETHICK1;

  B6:=BACKSET(A6《REF(A6,1),2);

  IF(B6,A6,DRAWNULL),COLOR33FF20,LINETHICK1;

  B7:=BACKSET(A7《REF(A7,1),2);

  IF(B7,A7,DRAWNULL),COLOR33FF20,LINETHICK1;