通达信开口涨指标公式


  N:=16;

  M:=6;

  MAV:=(C*2+H+L)/4;

  SK:=EMA(MAV,13) - EMA(MAV,34);

  SD:=EMA(SK,5);

  中轴:0;

  空方主力 : (-2*(SK-SD))*30.8,COLORLIGREEN;

  多方主力 : (2*(SK-SD))*30.8,COLORMAGENTA;

  持股:IF(多方主力》REF(多方主力,1),多方主力,DRAWNULL),COLORRED,LINETHICK2;

  持币:IF(空方主力》REF(空方主力,1),空方主力,DRAWNULL),COLORGREEN,LINETHICK2;

  AA05:=MA(C,5);

  AA10:=MA(C,10);

  BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;

  AA30:=MA(C,30);

  速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);

  加速度5:=EMA((速度5-REF(速度5,1)),3);

  三拾日乖离率:=(C-AA30)/AA30*100;

  加:=FILTER(COUNT(CROSS(BB05,30),5)》=1 AND AA05》REF(AA05,1) AND 三拾日乖离率》REF(三拾日乖离率,1) AND AA10》REF(AA10,1)

  AND 加速度5》REF(加速度5,1) AND 速度5》REF(速度5,1) ,10) ;

  DRAWTEXT(加,0.1,‘←加’),COLORYELLOW;

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K:=SMA(RSV,2,1);

  D:=SMA(K,2,1);

  J:=3*K-2*D;

  J1:=REVERSE(J);

  AA:=REF(MA(C,1),10)》REF(MA(C,60),10);

  买点:=CROSS(J,J1) AND AA;

  STICKLINE(买点,多方主力,多方主力+0.3,1,0),COLOR0000FF;

  STICKLINE(买点,多方主力,多方主力+0.5,0.5,0),COLORWHITE;

  STICKLINE(买点,多方主力,多方主力+0.8,0,0),COLORYELLOW;

  DRAWTEXT(买点,多方主力,‘庄现!’),COLORYELLOW;

  三连阴:=LAST(C《O,3,0);

  {DRAWTEXT(三连阴,1,‘三连阴’),COLORBLUE;}

  三缩量:=LAST(VOL《REF(VOL,1),3,0);

  {DRAWTEXT(三缩量,-2.5,‘三缩量’),COLORLIRED;}

  选股:REF(三连阴,1)》0 AND REF(三缩量,1)》0 AND O《C,COLORLIRED;

  DRAWTEXT(选股,1,‘选股’),COLORLIRED;

  TR1:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);

  HD :=HIGH-REF(HIGH,1);

  LD :=REF(LOW,1)-LOW;

  DMP:=EXPMEMA(IF(HD》0&&HD》LD,HD,0),N);

  DMM:=EXPMEMA(IF(LD》0&&LD》HD,LD,0),N);

  PDI:=DMP*100/TR1;

  MDI:=DMM*100/TR1;

  ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);

  ADXR:=EXPMEMA(ADX,M);

  买:(CROSS(PDI, MDI)AND CROSS(PDI, ADX)AND CROSS(PDI, ADXR))AND CLOSE》OPEN

  AND C/REF(C,1)》0.5 AND VOL》MA(VOL,5)*1.5,COLORRED;

  DRAWTEXT(买,0.8,‘买’),COLORRED;

  CI背离买:=LAST(MA(C,5)《MA(C,10),5,0) AND “CCI.CCI”》REF(“CCI.CCI”,1) AND CROSS(“CCI.CCI”,-100);

  DRAWTEXT(CI背离买,持股-3,‘CI背离买’),COLORLIGRAY;

  平台起飞:LAST((H-L)/REF(C,1)《0.1,5,0) AND VOL》REF(VOL,1)*2 AND C》REF(C,1)*1.05,COLORLIMAGENTA;

  DRAWTEXT(平台起飞,-4,‘平台起飞’),COLORLIMAGENTA;

  山谷停板:LAST(MA(C,5)《MA(C,10),5,0) AND C》REF(C,1)*1.098;

  DRAWTEXT(山谷停板,7,‘山谷停板’),COLORGREEN;

  A:=(C-REF(C,1))/REF(C,1)*100;

  A1:=REF(A,1);

  A2:=REF(A1,1);

  A3:=REF(A2,1);

  A4:=REF(A3,1);

  B:=CLOSE》=HIGH;

  拨云见日:A4《0 AND A3《0 AND A2《0 AND A1《-4 AND B AND A》=5;

  DRAWTEXT(拨云见日,9,‘拨云见日’),COLORBROWN;

  P1:=5;

  P2:=11;

  BIAS1:=(CLOSE-MA(CLOSE,P1))/MA(CLOSE,P1)*100;

  BIAS2:=(CLOSE-MA(CLOSE,P2))/MA(CLOSE,P2)*100;

  BIAS绝密买点:=CROSS(BIAS1,BIAS2) AND BIAS1》REF(BIAS1,1) AND MA(C,40)》REF(MA(C,40),1);

  {DRAWTEXT(BIAS绝密买点,-2,‘绝密买点’),COLORMAGENTA;}

  南天一柱:=C《O AND VOL》REF(VOL,1)*1.5 AND LAST(VOL《REF(VOL,1),5,1),COLORLIBLUE;

  {DRAWTEXT(南天一柱,6,‘南天一柱’),COLORLIBLUE;}

  AAA:=C》O AND V》REF(V,1)*2.5 AND CROSS(C,MA(C,5));

  BBA:=C》O AND V》REF(V,1)*10;

  顶天立地:AAA OR BBA;

  {DRAWTEXT(顶天立地,5,‘顶天立地’),COLORLICYAN;}

  {有人要求的B点选股源码}

  {信号出现请仔细确认其有效性}

  选:=(CLOSE+HIGH+LOW)/3;

  股:=EMA(选,10);

  用:=REF(股,1);

  BS决策:CROSS(股,用);

  STICKLINE(BS决策,多方主力,空方主力,0.5,0),COLORWHITE;

  {DRAWTEXT(BS决策,空方主力-8,‘BS决策’),COLORWHITE;}

  MA13:=MA(CLOSE,13);

  X1:=(C+L+H)/3;

  BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;

  EMA8:=EMA(C,8);

  {DRAWTEXT(FILTER(BB13》1 AND EMA(X1,13)》REF(EMA(X1,8),1),10),

  多方主力+1,‘∠45’),COLORWHITE;}

  压力:=MA(REF(HHV(C,30),1),2),COLOR9DFFFF;

  支撑:=MA(REF(LLV(C,30),1),2),COLORABFF46;

  AA1:=AMOUNT/V;BB1:=L《AA1*0.9;

  CC1:=(C-REF(C,1))/REF(C,1)*100》1.2;

  DD1:=L《MA(C,5)*0.921;EE1:=V《MA(V,5)*1.5;

  FF1:=BB1 AND CC1 AND DD1 AND EE1;

  {DRAWTEXT(FF1,0-1,‘老鼠仓’),COLOR4080FF;}

  A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);

  黑马线:=EMA(A51,5);

  A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;

  趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));

  {DRAWTEXT(CROSS(趋势线,0)AND 黑马线《40,多方主力+1,‘▲大黑马’),COLORYELLOW;}

  LC:=REF(CLOSE,1);

  RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);

  FF:=EMA(CLOSE,3);

  MA15:=EMA(CLOSE,21);

  DRAWTEXT(CROSS(FF,MA15),空方主力,‘底背’),COLORA6E500;

  DRAWTEXT(CROSS(88,RSI),多方主力,‘顶背’),COLOR1880FF;

  VAR2:=LLV(LOW,27);

  VAR3:=HHV(HIGH,34);

  VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*25;

  注意买:=IF((VAR4《10),80,100);

  RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

  K1:=SMA(RSV1,2,1);

  D1:=SMA(K1,2,1);

  JJ:=3*K1-2*D1;

  超跌:=IF(JJ《0,10,0);

  BDDD:=LLV(JJ,2)=LLV(JJ,8);

  买入:=IF(CROSS(JJ,REF(JJ+0.01,1)) AND BDDD AND JJ《20,30,0);

  {DRAWTEXT(买入 AND 注意买=100 AND 超跌=0,空方主力-5,‘短线’),COLOR8000FF;}

  MTM:=C-REF(C,1);

  DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

  买2:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX《0,2) AND CROSS(DX,MA(DX,2)),1,0);