通达信楚风布林BS主图指标公式


  M1:=5;

  M2:=10;

  M3:=20;

  M4:=30;

  M5:=40;

  M6:=60;

  M7:=90;

  M8:=120;

  M9:=250;

  N:=26;

  M:=2;

  CV:=CLOSE;

  BBIBOLL:(MA(CV,3)+MA(CV,6)+MA(CV,12)+MA(CV,24))/4;

  UPR:BBIBOLL+M*STD(BBIBOLL,N);

  DWN:BBIBOLL-M*STD(BBIBOLL,N);

  MA1:MA(CLOSE,M1);

  MA2:MA(CLOSE,M2);

  MA3:MA(CLOSE,M3);

  MA4:MA(CLOSE,M4);

  MA5:MA(CLOSE,M5);

  MA6:MA(CLOSE,M6);

  MA7:MA(CLOSE,M7);

  MA8:MA(CLOSE,M8);

  MA9:MA(CLOSE,M9);

  MA10:MA(C,10),COLORYELLOW;

  MA21:MA(C,21),COLORE66878;

  MA30:MA(C,30),COLORWHITE;

  MA120:MA(C,120),COLOR399C7F,POINTDOT;

  MA240:MA(C,240),COLOR000999,POINTDOT;

  X1:=(C+L+H)/3;

  X2:=EMA(X1,6);

  X3:=EMA(X2,5);

  DRAWICON(CROSS(X2,X3),L*0.98,7);

  DRAWICON(CROSS(X3,X2),H*1.02,8);

  STICKLINE(X2》=X3,LOW,HIGH,0.1,1),COLORRED;

  STICKLINE(X2》=X3,CLOSE,OPEN,2,2),COLORRED;

  STICKLINE(X2》=X3,CLOSE,OPEN,2,8),COLORBROWN;

  STICKLINE(X2《X3,LOW,HIGH,0.1,1),COLORGREEN;

  STICKLINE(X2《X3,CLOSE,OPEN,2,2),COLORGREEN;

  STICKLINE(CROSS(X2,X3),OPEN,CLOSE,2,1),COLORYELLOW;

  STICKLINE(CROSS(X3,X2),OPEN,CLOSE,2,1),COLORBLUE;