通达信无忧箱体主图指标公式


  向上跳空:=LOW》REF(HIGH,1);

  STICKLINE(向上跳空,LOW,REF(HIGH,1),10,0),COLORWHITE;

  下突缺口:=HIGH《REF(LOW,1),COLORGREEN;

  STICKLINE(下突缺口,HIGH,REF(LOW,1),10,0),COLORWHITE;

  AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/

  (HHV(HIGH,30)-LLV(LOW,30))*100,8);

  BA:=EMA(AB,5);

  A1{高}:=REFDATE(REF(HHV(H,96),5),DATE);

  B1{低}:=REFDATE(REF(LLV(L,96),5),DATE);

  D{中}:=((A1)+(B1))/2;

  五:=MA(C,5)LINETHICK2,COLOR00FFFF;

  二O:=EMA(C,20),COLORMAGENTA;

  空仓:IF(AB-BA《0,五,DRAWNULL),LINETHICK2,COLOR00FFFF;

  持仓:IF(AB-BA》0,五,DRAWNULL),,LINETHICK2,COLORRED;

  箱顶:IF(AB》0 AND AB-BA《=0,A1,A1),LINETHICK3,COLOR00FF00;

  箱腰:IF(AB》0 AND AB-BA《=0,D,D),LINETHICK3,COLOR00FF00;

  箱低:IF(AB》0 AND AB-BA《=0,B1,B1),LINETHICK3,COLOR00FF00;

  _____五:IF(CURRBARSCOUNT=6,L*0.992-0.02,DRAWNULL),

  CROSSDOT,COLORWHITE,LINETHICK3;{五日转点}

  十:IF(CURRBARSCOUNT=11,L*0.992-0.02,DRAWNULL),

  CROSSDOT,COLORYELLOW,LINETHICK3;{十日转点}

  二十:IF(CURRBARSCOUNT=21,L*0.992-0.02,DRAWNULL),

  CROSSDOT,COLORRED,LINETHICK3;{二十日转点};

  三十:IF(CURRBARSCOUNT=31,L*0.992-0.02,DRAWNULL),

  CROSSDOT,COLORCYAN,LINETHICK3;{三十日转点};

  六十:IF(CURRBARSCOUNT=61,L*0.992-0.02,DRAWNULL),

  CROSSDOT,COLORYELLOW,LINETHICK3;{六十日转点};

  九十:IF(CURRBARSCOUNT=91,L*0.992-0.02,DRAWNULL),

  CROSSDOT,COLORYELLOW,LINETHICK3;{九十日转点};

  高1:IF(AB》0 AND AB-BA》0,A1,DRAWNULL),LINETHICK3,COLORRED;

  中1:IF(AB》0 AND AB-BA》0,D,DRAWNULL),LINETHICK3,COLORRED;

  低1:IF(AB》0 AND AB-BA》0,B1,DRAWNULL),LINETHICK3,COLORRED;

  C2:=REF(C,1);

  涨停:=IF((C-C2)*100/C2》=(10-0.01*100/C2),1,0);

  STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;

  STICKLINE(涨停,H,L,0,0),COLORRED;

  跌停:=IF((C2-C)*100/C2》=(10-0.01*100/C2),1,0);

  STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;

  STICKLINE(跌停,H,L,0,1),COLORGREEN;

  {选股}

  HHH:=CROSS(C,MA(L+(H-L)/2,25)*0.95);LLL:=CROSS(MA(L+(H-L)/2,25)*0.95,C);

  CCC:=CROSS(H,MA(L+(H-L)/2,25)*1.15);DDD:=CROSS(H,MA(L+(H-L)/2,25)*1.25);

  DRAWTEXT(HHH AND MA(L+(H-L)/2,75)》=REF(MA(L+(H-L)/2,75),1),L*0.98,‘买了’),COLOR6699FF;

  DRAWTEXT(CCC AND MA(L+(H-L)/2,75)》=REF(MA(L+(H-L)/2,75),1),H*1.02,‘卖了’),COLOR6699FF;

  DRAWTEXT(DDD AND MA(L+(H-L)/2,75)》=REF(MA(L+(H-L)/2,75),1),H*1.02,‘小心顶’),COLOR6699FF;

  VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));

  VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));

  VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));

  DIR1:=ABS(CLOSE-REF(CLOSE,5));

  VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);

  ER1:=DIR1/VIR1;

  CS1:=ER1*(0.8-2/8)+2/8;

  CQ1:=CS1*CS1;

  DIR2:=ABS(CLOSE-REF(CLOSE,10));

  VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);

  ER2:=DIR2/VIR2;

  CS2:=ER2*(0.8-2/24)+2/24;

  CQ2:=CS2*CS2;

  STICKLINE(VAR2 《 MA(VAR3,6),LOW,HIGH,0,1),COLORLIBLUE;

  STICKLINE(VAR2 》 MA(VAR3,6),LOW,HIGH,0,1),COLORRED;

  STICKLINE(((OPEN》CLOSE)AND(VAR2《MA(VAR3,6))),(CLOSE-0.03),OPEN,3.05,0),COLORLIBLUE;

  STICKLINE(((OPEN《CLOSE)AND(VAR2《MA(VAR3,6))),CLOSE,OPEN,3.05,1),COLORLIBLUE;

  STICKLINE(((OPEN》CLOSE)AND(VAR2》MA(VAR3,6))),OPEN,(CLOSE-0.03),3.05,0),COLORRED;

  STICKLINE(((OPEN《CLOSE)AND(VAR2》MA(VAR3,6))),OPEN,CLOSE,3.05,1),COLORRED;

  DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW - (LOW*0.02)),7);

  DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH+(HIGH*0.02)),8);

  PT:=REF(H,1)-REF(L,1);

  CDP:=(REF(H,1)+REF(L,1)+REF(C,1)*2)/4;

  AH:=CDP+PT;

  AL:=CDP-PT;

  NH:=CDP*2-REF(L,1);

  NL:=CDP*2-REF(H,1);

  强:IF(AH》REF(C,1)*1.1,REF(C,1)*1.1,AH)NODRAW;

  阻:IF(NH》强,(强-CDP)*0.618+CDP,NH)NODRAW,COLORBLUE;

  M:=IF(AL《REF(C,1)/1.1,REF(C,1)/1.1,AL);

  撑:IF(NL《M,CDP-(CDP-M)*0.618,NL)NODRAW;

  底:IF(AL《REF(C,1)/1.1,REF(C,1)/1.1,AL)NODRAW;

  {量能饱和度}

  SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));

  【量能饱和】:=IF(SAT》1,1,SAT)*100,COLORYELLOW,NODRAW;

  {活跃度}

  LC:=REF(CLOSE,1);

  RSI5:=(SMA(MAX(CLOSE-LC,0),3,1))/(SMA(ABS(CLOSE-LC),3,1))*100;

  WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;

  活跃度:=(RSI5-WR10),COLORFFFF00,LINETHICK1,NODRAW;

  活跃度比:=IF(活跃度》=0,(活跃度+100)/2,100-ABS((活跃度-100)/2));

  T:=MA(HIGH-LOW,20);

  C8:=CLOSE/REF(CLOSE,1)》1.09 AND CLOSE/REF(CLOSE,1)《1.11 AND CLOSE==HIGH;

  DRAWICON(PERIOD==5 AND C8,CLOSE+T*1.25,9);

  V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);

  STICKLINE(V2》=1,O,C,2,0),COLORYELLOW;

  DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIF,9);

  MACD:=(DIF-DEA)*2,COLORSTICK;

  VA1:=HHVBARS(H,BARSLAST(MACD《0)+1);

  VA2:=CROSS(BACKSET(CROSS(0,MACD),REF(VA1,1)+2),0.5);

  JQG:=DRAWLINE(VA2,H,REF(VA2,1),REF(H,1),1),COLORGREEN,DOTLINE;{在价格画线}

  NOTEXT前高A:DRAWLINE(VA2,H,ISLASTBAR,REF(H,BARSLAST(VA2)),1),COLORWHITE,DOTLINE;

  DRAWNUMBER(ISLASTBAR,NOTEXT前高A,NOTEXT前高A),COLORWHITE;

  VA3:=LLVBARS(L,BARSLAST(MACD》0)+1);

  VA4:=CROSS(BACKSET(CROSS(MACD,0),REF(VA3,1)+2),0.5);

  NOTEXT前低A:DRAWLINE(VA4,L,ISLASTBAR,REF(L,BARSLAST(VA4)),1),COLORWHITE,DOTLINE;

  DRAWNUMBER(ISLASTBAR,NOTEXT前低A,NOTEXT前低A),COLORWHITE;

  基准:=CONST(SUM(VA2,0));

  前高4:=基准-4=SUM(VA2,0) AND VA2,COLORWHITE,NODRAW;

  前高3:=基准-3=SUM(VA2,0) AND VA2,COLORWHITE,NODRAW;

  前高2:=基准-2=SUM(VA2,0) AND VA2,COLORWHITE,NODRAW;

  前高1:=基准-1=SUM(VA2,0) AND VA2,COLORYELLOW,NODRAW;

  前高:=基准=SUM(VA2,0) AND VA2,COLORCYAN,NODRAW;

  距离G1:=BARSLAST(前高1);

  距离G2:=BARSLAST(前高2);

  距离G3:=BARSLAST(前高3);

  距离G4:=BARSLAST(前高4);

  NOTEXTG1:DRAWLINE(前高1,H,前高 AND H》=REF(H,距离G1),H,0),COLORYELLOW;

  NOTEXTG2:DRAWLINE(前高1,H,前高 AND H《REF(H,距离G1),H,0),COLORGREEN;

  NOTEXTG3:DRAWLINE(前高2,H,前高1 AND H》=REF(H,距离G2),H,0),COLORYELLOW;

  NOTEXTG4:DRAWLINE(前高2,H,前高1 AND H《REF(H,距离G2),H,0),COLORGREEN;

  NOTEXTG5:DRAWLINE(前高3,H,前高2 AND H》=REF(H,距离G3),H,0),COLORYELLOW;

  NOTEXTG6:DRAWLINE(前高3,H,前高2 AND H《REF(H,距离G3),H,0),COLORGREEN;

  NOTEXTG7:DRAWLINE(前高4,H,前高3 AND H》=REF(H,距离G4),H,0),COLORYELLOW;

  NOTEXTG8:DRAWLINE(前高4,H,前高3 AND H《REF(H,距离G4),H,0),COLORGREEN;

  基准2:=CONST(SUM(VA4,0));

  前低:=基准2=SUM(VA4,0) AND VA4;

  前低1:=基准2-1=SUM(VA4,0) AND VA4;

  前低2:=基准2-2=SUM(VA4,0) AND VA4;

  前低3:=基准2-3=SUM(VA4,0) AND VA4;

  前低4:=基准2-4=SUM(VA4,0) AND VA4;

  距离D1:=BARSLAST(前低1);

  距离D2:=BARSLAST(前低2);

  距离D3:=BARSLAST(前低3);

  距离D4:=BARSLAST(前低4);

  NOTEXTD1:DRAWLINE(前低1,L,前低 AND L》=REF(L,距离D1),L,0),COLORYELLOW;

  NOTEXTD2:DRAWLINE(前低1,L,前低 AND L《REF(L,距离D1),L,0),COLORGREEN;

  NOTEXTD3:DRAWLINE(前低2,L,前低1 AND L》=REF(L,距离D2),L,0),COLORYELLOW;

  NOTEXTD4:DRAWLINE(前低2,L,前低1 AND L《REF(L,距离D2),L,0),COLORGREEN;

  NOTEXTD5:DRAWLINE(前低3,L,前低2 AND L》=REF(L,距离D3),L,0),COLORYELLOW;

  NOTEXTD6:DRAWLINE(前低3,L,前低2 AND L《REF(L,距离D3),L,0),COLORGREEN;

  NOTEXTD7:DRAWLINE(前低4,L,前低3 AND L》=REF(L,距离D4),L,0),COLORYELLOW;

  NOTEXTD8:DRAWLINE(前低4,L,前低3 AND L《REF(L,距离D4),L,0),COLORGREEN;