通达信小六壬指南指标公式


  小六壬是一个古传的数术预测法,今用于股市上,也具有一定效验具体用法:各位常用的交易信号发出时,配合小六壬的信号,如果二者相同,可交易,不同,需要小心。

  OINC:=INTPART(C);

  OIN1C:=C*100-OINC*100;

  OLR0C:=MOD(OINC,6);

  OLRC:=IF(OLR0C=0,6,OLR0C);

  OLR01C:=MOD(OIN1C,6);

  OLR1C:=IF(OLR01C=0,6,OLR01C);

  OXL1C:=MOD(OLRC+OLR1C-1,6);

  XLRC:=IF(OXL1C=0,6,OXL1C);

  DRAWNUMBER(1,0.6,XLRC);

  {MA多空交易信号}

  M5:=MA(C,5);

  M10:=MA(C,10);

  MKD:=M5》M10 AND L《M5;{看多}

  MK:=L《M5 AND L《M10 AND H》M5 AND H》M10; {平}

  MKK:=M5《M10 AND H《M5;{看空}

  MKK1:=C《O AND REF(C,1)《REF(O,1) AND REF(C,2)《REF(O,2);{三连阴}

  XD:=C》O AND C》M10;

  XK:=C《O AND C《M10;

  {=== 小六壬信号 ===+买卖点}

  B:IF(XLRC=1 AND MK AND XD,1,0);

  S:IF(XLRC=4 AND MK AND XK,0,1);

  {+抄底}

  B1:IF(C《O AND MKK AND MKK1 AND C《REF(C,1) AND REF(C,1)《REF(C,2) AND REF(C,2)《REF(C,3)

  AND XLRC=3,0.5,0),COLORRED;

  {+主升}

  B2:DRAWICON(XLRC=3 AND MKD AND XD,0.1,1);