通达信终极黄金主图指标公式


  DIFF:=EMA(C,5)-EMA(C,20);

  DEA:=EMA(DIFF,10);

  MACD:=2*(DIFF-DEA);

  JC:=CROSS(DIFF,DEA);

  SC:=CROSS(DEA,DIFF);

  DCJC:=JC AND DEA》0;

  VAR1:=1;

  VAR2:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)*100;

  VAR3:=CLOSE》OPEN AND OPEN-LOW》HIGH-CLOSE;

  VAR4:=REF(VAR2,1)《-20 AND VAR3;

  VAR5:=REF(VAR2,1)《-20 AND CLOSE》OPEN AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000》20;

  VAR6:=FILTER(VAR4 OR VAR5,3);

  VAR7:=OPEN》CLOSE AND HIGH-IF(CLOSE》OPEN,CLOSE,OPEN)》IF(OPEN《CLOSE,OPEN,CLOSE)-LOW;

  VAR8:=REF(VAR2,1)》ABS(-20) AND VAR7;

  VAR9:=REF(VAR2,1)》ABS(-20) AND CLOSE《OPEN AND (REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*1000》20;

  VARA:=FILTER(VAR8 OR VAR9,3);

  VARB:=CLOSE》OPEN AND OPEN-LOW》HIGH-CLOSE;

  VARC:=REF(VAR2,1)《-13 AND VAR3;

  VARD:=REF(VAR2,1)《-13 AND CLOSE》OPEN AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000》20;

  VARE:=FILTER(VARC OR VARD,3);

  VARF:=OPEN》CLOSE AND HIGH-IF(CLOSE》OPEN,CLOSE,OPEN)》IF(OPEN《CLOSE,OPEN,CLOSE)-LOW;

  VAR10:=REF(VAR2,1)》ABS(-13) AND VAR7;

  VAR11:=REF(VAR2,1)》ABS(-13) AND CLOSE《OPEN AND (REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*1000》20;

  VAR12:=FILTER(VAR10 OR VAR11,3);

  DRAWTEXT(VARE*VAR1》0,LOW,‘短线关注’),COLORRED;

  DRAWTEXT(VAR12*VAR1》0,HIGH,‘控制风险’),COLORCYAN ;

  LC:=REF(CLOSE,1);

  RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

  DRAWTEXT(CROSS(84,RSI) , HIGH,‘→ 逃顶 ’),COLORBLUE ;

  DRAWTEXT(CROSS(RSI,11) , LOW,‘→ 低吸 ’),COLORRED ;

  JJ:=(CLOSE+HIGH+LOW)/3;

  A:=EMA(JJ,5);

  B:=REF(A,1);

  终极黄金:STICKLINE(A》B,A,B,5,0),COLORC44CF0;

  一卸千里:STICKLINE(A《B,A,B,5,0),COLORBLUE;

  天籁:HHV(HIGH,35),COLORRED,LINETHICK2;

  地籁:LLV(LOW,55),COLORRED,LINETHICK2;

  三十四日:MA(CLOSE,34);

  八十九日:MA(CLOSE,89);

  一百四十四日:MA(CLOSE,144);

  无穷成本均线: DMA(CLOSE,VOL/CAPITAL),LINETHICK2;