专抄底短线王副图(通达信)


  本(专抄底短线王)公式包含未来函数,只作参考,买卖在个人,祝你一本万利。

  V1:=MA(C,3)=HHV(MA(C,3),7);

  V2:=MA(C,3)》MA(C,5);

  V3:=MA(V,5)》MA(V,10)*1.0

  V4:=COUNT(MA(C,1)》REF(C,1),2)=2;

  LC20:=REF(CLOSE,1);

  RSI20:=SMA(MAX(CLOSE-LC20,0),4.1,1)/SMA(ABS(CLOSE-LC20),4.1,1)*100;

  STICKLINE(CROSS(RSI20,11)*1,-10,20,2,0),COLORYELLOW;

  VAR3A:=3;

  VAR2A:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

  MTM:=C-REF(C,1);

  DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

  YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX《0,2) AND CROSS(DX,MA(DX,2)),1,0);

  加仓:IF(FILTER(YXF=1,5),20,-10),STICK,LINETHICK3;

  A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV

  (L,55))*100,5,1);

  FY:=EMA(A51,5);

  A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;

  VAR2:=TROUGHBARS(3,15,1)《10;

  VAR3:=PEAKBARS(3,15,1)《5;

  VAR4:=IF(VAR2=1,50,0);

  VAR5:=IF(VAR3=1,50,0);

  底部:=IF(VAR4=50,10,0);

  头部:=IF(VAR5=50,20,60);

  未来买入:IF(底部=10 AND REF(底部,1)=10 AND REF(底部,2)=0,50,0),COLOR0000CC,LINETHICK2;

  未来卖出:IF(头部=20 AND REF(头部,1)=20 AND REF(头部,2)=60,20,60),COLORGREEN,LINETHICK2;

  参考买入延迟线:底部,LINETHICK1 ,COLORMAGENTA;

  LT:=100;

  LU:=0;

  LV:=38.2;

  LA:=REF(CLOSE,1);

  LB:=((SMA(MAX((CLOSE - LA),0),5,1) / SMA(ABS((CLOSE - LA)),5,1)) * 100);

  LC:=(HIGH - REF(HIGH,1));

  LD:=(REF(LOW,1) - LOW);

  LE:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);

  LF:=SUM(IF(((LC 》 0) AND (LC 》 LD)),LC,0),10);

  LG:=SUM(IF(((LD 》 0) AND (LD 》 LC)),LD,0),10);

  LH:=((LF * 100) / LE);

  LI:=((LG * 100) / LE);

  LJ:=MA(((ABS((LI - LH)) / (LI + LH)) * 100),5);

  AV:=(LB + LJ);

  LK:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));

  LL:=(LB - LK);

  LM:=(AV + LL);

  LO:=((((2 * CLOSE) + HIGH) + LOW) / 4);

  LP:=LLV(LOW,34);

  LQ:=HHV(HIGH,34);

  LR:=EMA((((LO - LP) / (LQ - LP)) * 100),13);

  LS:=EMA(((0.667 * REF(LR,1)) + (0.333 * LR)),2);

  向导线:=LLV(LM,1);

  STICKLINE((向导线》225),95,90,4,1),COLORFFCC00;

  STICKLINE((向导线》235),100,95,4,1),COLORRED;

  STICKLINE(CROSS(235,向导线),100,90,4,1),COLOR00FF00;

  STICKLINE((LM《(0-1)),0,5,4,1),COLOR00FF00;

  STICKLINE((LM《(0-5)),5,10,4,1),COLORYELLOW;

  STICKLINE(CROSS(向导线,(0-3)),0,10,4,1),COLORRED;

  BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

  BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

  BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

  BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;

  乖离:=MA(BIAS,3);

  底一:IF(乖离《-12 AND 乖离》=-18,-4,0), COLORCYAN,LINETHICK1;

  STICKLINE(乖离《-12 AND 乖离》=-18,2,0,6,0) , COLORCYAN;

  底二:IF(乖离《-18,3,0),COLORFF35FF,LINETHICK1;

  STICKLINE(乖离《-18,3,0,6,0),COLORFF35FF;

  底三:IF(乖离《-6,5,0),COLORRED,LINETHICK1;

  STICKLINE(乖离《-6,5,3,2,1),COLORRED;

  底四:IF(乖离《-4.5,0,0),COLOR00FFFF,LINETHICK1;

  STICKLINE(乖离《-4.5,0,1,3,1),COLOR00FFFF;

  买:=(ZIG(3,5)》REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)《=REF(ZIG(3,5),2)) AND (REF(ZIG

  (3,5),2)《=REF(ZIG(3,5),3));

  卖:=(ZIG(3,5)《REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)》=REF(ZIG(3,5),2)) AND (REF(ZIG

  (3,5),2)》=REF(ZIG(3,5),3));

  STICKLINE((买=1),(-10),0,1,0),COLOR0000FF;

  DRAWTEXT((买=1),(-12),‘买’),COLOR0000FF;

  STICKLINE((卖=1),10,0,1,0),COLOR00FF00;

  DRAWTEXT((卖=1),19,‘卖’),COLOR00FF00;

  VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

  VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

  ((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

  ((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  VAR11:=VARF《REF(VAR10,1) AND VOL》REF(VOL,1) AND CLOSE》REF(CLOSE,1);

  DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,15,‘大资金活动’),LINETHICK1,COLORFF00FF;

  STICKLINE(VAR11 AND COUNT(VAR11,30)=1,1,10,5,0),COLORFF00FF;

  VAR12:=(HIGH+LOW+CLOSE)/3;

  VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));

  VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));

  VAR15:=IF(VAR13》=150 AND VAR13《200 AND VAR14》=150 AND VAR14《200,10,0);

  VAR16:=IF(VAR13《=-150 AND VAR13》-200 AND VAR14《=-150 AND VAR14》-200,-10,VAR15);

  VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

  VAR18:=100-ABS(VAR17);

  VAR19:=IF(VAR18《90,VAR18,100);

  VAR1A:=IF(VARE》0,VARE,0);

  VAR1B:=IF(VAR14》=200 AND VAR13》=150,15,IF(VAR14《=-200 AND VAR13《=-150,-15,VAR16))+60;

  VAR1C:=VAR1A》48 AND VAR1B》60 AND VAR19《100;

  DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,15,‘大笔出货’),LINETHICK1,COLORFFCC66;

  STICKLINE(VAR1C AND COUNT(VAR1C,30)=1,0,10,5,0),COLORFFCC66;

  P1:=5;

  P2:=4;

  VARA:=LLV(LOW,P1);

  VARB:=HHV(HIGH,P1);

  K: EMA((CLOSE-VARA)/(VARB-VARA)*100,P2),COLORLIMAGENTA;

  D: EMA(0.667*REF(K,1)+0.333*K,2),COLORWHITE;