大智慧锁心葬爱指标公式


  DRAWRECTABS(0,0,30,32,rgb(250,60,80)),color000099;

  DRAWRECTABS(0,30,30,33,rgb(250,250,80)),colorred;

  DRAWTEXTABS(2,5,‘锁心’),colorFFFFFF,LINETHICK1;

  DRAWTEXTABS(2,18,‘葬爱’),colorFFFFFF,LINETHICK1;

  DRAWGBKLAST(v》1,STRIP(RGB(0,0,205),RGB(60,179,113),0));

  n:=14;m:=6;

  TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N);

  HD := HIGH-REF(HIGH,1);

  LD := REF(LOW,1)-LOW;

  DMP:= SUM(IF(HD》0 AND HD》LD,HD,0),N);

  DMM:= SUM(IF(LD》0 AND LD》HD,LD,0),N);

  PDI: DMP*100/TR,colorwhite;

  MDI: DMM*100/TR,coloryellow;

  ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M),colorff00ff;

  ADXR:(ADX+REF(ADX,M))/2,colorgreen;

  VAR2:=MA(CLOSE,5);

  VAR3:=MA(CLOSE,10);

  VAR4:=MA(CLOSE,20);

  VAR5:=MA(CLOSE,30);

  VAR6:=((((VAR2 + VAR3) + VAR4) + VAR5) / 4);

  VAR7:=(((VAR6 - REF(VAR6,15)) / REF(VAR6,15)) * 100);

  VAR9:=EMA(VAR7,5);

  稳胜:STICKLINE(((VAR7 》 REF(VAR7,1)) AND (VAR7 》 0)),0,VAR9,5,0),colorFF00FF;

  STICKLINE(((VAR7 》 REF(VAR7,1)) AND (VAR7 《 0)),VAR7,VAR9,5,0),color0000FF;

  震荡:STICKLINE(((VAR9 》 REF(VAR9,1)) AND (VAR9 《 0)),VAR7,0,5,0),colorFF0000;

  做多:STICKLINE((VAR9 》 REF(VAR9,1)),VAR7,VAR9,5,0),color0000FF;

  禁区:STICKLINE(CROSS(VAR7,0),VAR7,VAR9,8,0),colorFFFFFF;

  持币:STICKLINE((VAR7 《 REF(VAR7,1)),VAR7,VAR9,5,1),color00FF00;

  回调:STICKLINE(((VAR7 《 REF(VAR7,1)) AND (VAR9 》 (1 * REF(VAR9,1)))),VAR7,VAR9,10,0),color00EEFF;

  STICKLINE((((VAR7 《 REF(VAR7,1)) AND (VAR9 》 (1 * REF(VAR9,1)))) AND (VAR7 》 0)),0,VAR9,5,0),colorFF00FF;0;

相关信息