大智慧飞龙在天指标公式


  input:LONG(26,20,100),SHORT(12,5,40),M(9,2,60);

  a1:=1;

  a2:=DYNAINFO(14);

  a3:=(FINANCE2(37));

  a4:=(FINANCE2(3));

  a5:=DYNAINFO(17);

  a6:=(MA(CLOSE,0)) * a1;

  a7:=(MA(a6,0)) * a1;

  a8:=a6 - a7;

  STICKLINE((a6 》 a7),a6,a7,0.8,501),linethick1,colorRed;

  STICKLINE((a7 》 a6),a6,a7,0.8,1),linethick1;

  DRAWICON(((CROSS(a7,a6)) AND (TIME 》 93200)),a6,8),colorGreen;

  DRAWICON(((CROSS(a6,a7)) AND (TIME 》 93200)),a6,7),colorYellow;

  a9:=(CLOSE = ((HHV(CLOSE,0)) * a1)) AND (VOL 》= 1000);

  a10:=VOL = (HHV(VOL,0));

  a11:=(STRFIND(STKNAME,‘ST’,1)) 》 0;

  a12:=(STRFIND(STKNAME,‘S’,1)) 》 0;

  a13:=NOT(a11) AND NOT(a12);

  a14:=SUM((((((a13 AND a9) AND a10) AND (CLOSE 》 (MA(CLOSE,0)))) AND (TIME 》 93500)) AND (TIME 《 145500)),0);

  a15:=((ALLBIDVOL / (ALLBIDVOL + ALLASKVOL)) * 100) * a1;

  a16:=(HIGH + LOW) / 2;

  a17:=(a14);

  a18:=(a15);

  a19:=(MA((MA(CLOSE,0)),0)) * a1;

  DRAWTEXT(((((a13 AND a9) AND a10) AND (TIME 》 93500)) AND (TIME 《 144500)),CLOSE,‘涨’),colorRed;

  DRAWTEXTABS(25,282,‘ ’),colorCyan;

  DRAWTEXTABS(25,302,‘ ’),colorCyan;

  DRAWTEXT((FILTER((((a5 》 1) AND (a14 》= 2)) AND (a8 》 0)),15)),a6,‘追涨’),linethick3,coloryellow;

  a3:=(FINANCE2(37));

  DRAWTEXTABS(100,282,‘ 流通股 ’+a3),colorGreen;

  a4:=(FINANCE2(3));

  DRAWTEXTABS(280,282,‘ 收益 ’+a4),colorWhite;

  DRAWTEXTABS(290,282,‘ 量对比 ’+a5),colorGreen;

  DRAWTEXTABS(25,262,‘敢死队’),colorCyan;

  DRAWTEXTABS(25,242,‘操盘最高境界就是敢于找死’),colorCyan;

  DRAWTEXTABS(25,222,‘涨停板敢死队,勇敢者的游戏。飞龙在天!’),linethick1,COLOR00EEff;

  a20:=(EMA(CLOSE,SHORT)) - (EMA(CLOSE,LONG));

  a21:=EMA(a20,M);

  a22:=2 * (a20 - a21);

  DRAWTEXT((FILTER(((a20 * a1) 》 0.2),30)),CLOSE,‘警报’),linethick2,colorGreen;

  DRAWTEXT((((FILTER(((a20 * a1) 《 -0.03),30)) AND (TIME 》 113500)) AND (a2 》 -0.02)),CLOSE,‘涨’),linethick3,colorRed;

相关信息