大智慧量价均数主图指标公式


  VARIABLE: zts=0,dts=0,量价=0,量价30=0,lj=0;

  MA110:MA(CLOSE,110),LINETHICK2,COLORBLUE;

  MA200:MA(C,200),COLORMAGENTA,LINETHICK2;

  MA600:MA(C,600),COLORRED,LINETHICK2;

  MA25:MA(C,25),COLORgreen,LINETHICK2;

  均价:=SUM(AMOUNT,1)/SUM(V,1)/100;

  量价均数:均价*AMOUNT/ SUM(AMOUNT,2) + REF(均价,1) * REF(AMOUNT,1)/ SUM(AMOUNT,2),COLORRED,linethick2;

  量价3:均价*AMOUNT/SUM(AMOUNT,4) + REF(均价,1) * REF(AMOUNT,1)/ SUM(AMOUNT,4) + REF(均价,2) * REF(AMOUNT,2)/ SUM(AMOUNT,4)+ REF(均价,3) * REF(AMOUNT,3)/ SUM(AMOUNT,4) ,colorYELLOW,linethick2;

  量价18:均价*AMOUNT/SUM(AMOUNT,18)

  + REF(均价,1) * REF(AMOUNT,1)/ SUM(AMOUNT,18)

  + REF(均价,2) * REF(AMOUNT,2)/ SUM(AMOUNT,18)

  + REF(均价,3) * REF(AMOUNT,3)/ SUM(AMOUNT,18)

  + REF(均价,4) * REF(AMOUNT,4)/ SUM(AMOUNT,18)

  + REF(均价,5) * REF(AMOUNT,5)/ SUM(AMOUNT,18)

  + REF(均价,6) * REF(AMOUNT,6)/ SUM(AMOUNT,18)

  + REF(均价,7) * REF(AMOUNT,7)/ SUM(AMOUNT,18)

  + REF(均价,8) * REF(AMOUNT,8)/ SUM(AMOUNT,18)

  + REF(均价,9) * REF(AMOUNT,9)/ SUM(AMOUNT,18)

  + REF(均价,10) * REF(AMOUNT,10)/ SUM(AMOUNT,18)

  + REF(均价,11) * REF(AMOUNT,11)/ SUM(AMOUNT,18)

  + REF(均价,12) * REF(AMOUNT,12)/ SUM(AMOUNT,18)

  + REF(均价,13) * REF(AMOUNT,13)/ SUM(AMOUNT,18)

  + REF(均价,14) * REF(AMOUNT,14)/ SUM(AMOUNT,18)

  + REF(均价,15) * REF(AMOUNT,15)/ SUM(AMOUNT,18)

  + REF(均价,16) * REF(AMOUNT,16)/ SUM(AMOUNT,18)

  + REF(均价,17) * REF(AMOUNT,17)/ SUM(AMOUNT,18)

  ,colorcyan,linethick3;

  VAR1:=MA(均价,18);

  VAR2:=(均价-VAR1)/VAR1*100;

  VAR3:=MA(VAR2,1);

  {www.gupang.com 股旁网_大智慧指标公式}

  AA:=IF(VAR3》REF(VAR3,1) AND VAR3》0 ,16,-8);

  BB:=IF(VAR3》REF(VAR3,1) AND VAR3《0 ,10,-8);

  CCC:=IF(VAR3《REF(VAR3,1) AND VAR3》0 ,8,-8);

  DD:=IF(VAR3《REF(VAR3,1) AND VAR3《0 ,8,-8);

  STICKLINE(AA=16,均价,OPEN,2.5,0),COLORYELLOW;

  STICKLINE(BB=10,均价,OPEN,2.5,0),COLORFF00FF;

  STICKLINE(CCC=8,均价,OPEN,2.5,0),COLOR400080;

  STICKLINE(DD=8,均价,OPEN,2.5,0),COLORFF0000;

  正冲击波:=IF(均价/REF(均价,1)》1.009,12,4);

  负冲击波:=IF(REF(均价,1)/均价》1.0091,8,4);

  STICKLINE(正冲击波=12,均价,C,1.5,0),COLORRED;

  STICKLINE(负冲击波=8,均价,C,1.5,0),COLORGREEN;

  if 正冲击波=12 then begin

  zts:=zts+1;

  dts:=0;

  end;

  if 负冲击波=8 then begin

  dts:=dts+1;

  zts:=0;

  end;

  drawtext(dts=0 and zts《》ref(zts,1),h*1.01,str(zts)),colorred,align1,valign0;

相关信息