大智慧波段雄鹰指标公式


  N1:=21;N2:=8;

  Var1:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  Var2:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;

  Var3:=SMA(SMA(Var2,3,1),3,1);

  Var4:=EMA(Var3,5);

  Var5:=LLV(LOW,26);

  Var6:=HHV(HIGH,34);

  Var7:=EMA((CLOSE-Var5)/(Var6-Var5)*4,4)*25;

  var8:=(2*c+h+l)/4;

  var9:=llv(low,N1);

  var10:=hhv(high,N2);

  Var2w:=100-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));

  MW:= EMA(Var2w,3);

  Var3w:=EMA(Var2w,7);

  M1:= EMA(Var3w,5);

  mb1:=CROSS(MW,M1) AND M1《20;

  mg1:=if(CROSS(M1,MW) AND REF(MW,1)》80,80 ,0) ;

  波段:ema((var8-var9)/(var10-var9)*100,9),colorRED;

  b1:ema(0.667*ref(波段,1)+0.333*波段,2),color00ff00;

  顶:if((BARSLAST(mg1》0)《2),80,100);

  底:IF((mb1),20,0);

  底预备: IF((Var7《10),50,30);

  顶预备: IF((Var7》90),50,70);

  0;100;

相关信息