大智慧虎步龙行指标公式


  DRAWTEXTABS(0,0,‘ ☆全功能KDJ+MAC☆’),colorgreen;

  {DRAWGBK(close》0,STRIP(RGB(25,25,112),RGB(47,79,79),0));}

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K:SMA(RSV,3,1),LINETHICK1,COLORWHITE;

  D:SMA(K,3,1),LINETHICK1,COLOR00DDDD;

  J:3*K-2*D,LINETHICK1,COLORred;

  DIFF:EMA(CLOSE,12)-EMA(CLOSE,26),linethick0,COLOR0099FF;

  DEA :EMA(DIFF,9),linethick0,COLORD89837;

  MACD:2*(DIFF-DEA),COLORFF9999,linethick0;

  YLZC:=if(close=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(vol+0.01)/100);

  阻价:=if(close=INDEXC,YLZC+INDEXC-INDEXl,YLZC+(close-low));

  支价:=if(close=INDEXC,INDEXl+INDEXC-YLZC,low+(close-YLZC));

  今压:REF(阻价,1),LINETHICK0,COLORAA11BB;

  今撑:REF(支价,1),LINETHICK0,COLOR009900;

  明压:阻价,LINETHICK0;

  明撑:支价,LINETHICK0;

  rsv1:=(hhv(h,9.8)-c)/(hhv(h,9.8)-llv(l,9.8))*101;

  kk:=sma(rsv1,3,1);

  dd:=sma(kk,3,1);

  jj:=3*kk-2*dd;

  买卖:=if(jj》=100,100,if(jj《=0,0,jj));

  明天买:if(买卖=100,0-10,0),color00cccc;

  明天卖:if(买卖=0,90,100),color00ff00;

  KX:=250;

  KH:=HHV(K,KX);

  DH:=HHV(D,KX);

  JH:=HHV(J,KX);

  KL:=LLV(K,KX);

  DL:=LLV(D,KX);

  JL:=LLV(J,KX);

  HKMAX:=MAX(KH,MAX(DH,JH));

  LKMIN:=MIN(KL,MIN(DL,JL));

  KHLB:=(HKMAX+LKMIN)/2;

  KHLC:=HKMAX-LKMIN;

  MHF:=HHV(DIFF,KX);

  MHD:=HHV(DEA,KX);

  MHM:=HHV(MACD,KX);

  MLF:=LLV(DIFF,KX);

  MLD:=LLV(DEA,KX);

  MLM:=LLV(MACD,KX);

  HMAX:=MAX(MHF,MAX(MHD,MHM));

  LMIN:=MIN(MLF,MIN(MLD,MLM));

  FHLB:=(HMAX-LMIN)/100;

  FHLC:=HMAX-LMIN;

  SH:=(0-FHLB)*(KHLC/FHLC)+KHLB;

  DIFFA:(DIFF-FHLB)*(KHLC/FHLC)+KHLB,linethick2;

  DEAA:(DEA-FHLB)*(KHLC/FHLC)+KHLB,linethick2;

  MACDA:=(macd-FHLB)*(KHLC/FHLC)+KHLB;

  CDA:=MACD《ref(MACD,1) and MACD》0;

  CDB:=MACD》=ref(MACD,1) and MACD》0;

  CDC:=MACD》ref(MACD,1) and MACD《0;

  CDD:=MACD《=ref(MACD,1) and MACD《0;

  {www.gupang.com 股旁网_大智慧股票指标公式}

  STICKLINE(CDA,SH,macda,6,0),COLOR00AAFF;{黄色段}

  STICKLINE(CDA,SH,macda,6.6,0),COLOR0066AA;

  STICKLINE(CDA,SH,macda,4.4,0),COLOR0099DD;

  STICKLINE(CDA,SH,macda,3.3,0),COLOR00BBEE;

  STICKLINE(CDA,SH,macda,2.2,0),COLOR00DDFF;

  STICKLINE(CDA,SH,macda,1.1,0),COLOR00FFFF;

  STICKLINE(CDB,SH,macda,6,0),COLOR0000AA; {红色段}

  STICKLINE(CDB,SH,macda,6.6,0),COLOR0011BB;

  STICKLINE(CDB,SH,macda,4.4,0),COLOr0022CC;

  STICKLINE(CDB,SH,macda,3.3,0),COLOR0033DD;

  STICKLINE(CDB,SH,macda,2.2,0),COLOR0044EE;

  STICKLINE(CDB,SH,macda,1.1,0),COLOR0055FF;

  STICKLINE(CDC,SH,macda,6,0),COLORAA00BB;{向上粉红}

  STICKLINE(CDC,SH,macda,6.6,0),COLORBB1177;

  STICKLINE(CDC,SH,macda,4.4,0),COLORCC2299;

  STICKLINE(CDC,SH,macda,3.3,0),COLORDD33AA;

  STICKLINE(CDC,SH,macda,2.2,0),COLOREE44BB;

  STICKLINE(CDC,SH,macda,1.1,0),COLORFF55BB;

  STICKLINE(CDD,SH,macda,6,0),COLORFF7700;

  STICKLINE(CDD,SH,macda,6.6,0),COLORAA7711;

  STICKLINE(CDD,SH,macda,4.4,0),COLORCC9922;

  STICKLINE(CDD,SH,macda,3.3,0),COLOREEBB33;

  STICKLINE(CDD,SH,macda,2.2,0),COLORFFCC44;

  STICKLINE(CDD,SH,macda,1.1,0),COLORFFDD55;

  PARTLINE(DIFFA,DIFF》0,RGB(255,153,153),DIFF《0,RGB(255,153,153));

  PARTLINE(DEAA,DEA》0,RGB(65,105,225),DEA《0,RGB(65,105,225));

  DRAWTEXT(BARSTATUS=2,SH,‘ 0’),color00aaaa;

  TYP:=(HIGH+LOW+CLOSE)/3;

  STICKLINE(diff》ref(diff,1),20,20,2,0),COLORRED;

  STICKLINE(diff《ref(diff,1),20,20,2,0),COLORGREEN;

  STICKLINE(K》=ref(K,1) or k》d and diff》ref(diff,1),80,80,2,1),COLORRED;

  STICKLINE(K《ref(K,1),80,80,2,1),COLORGREEN;

相关信息