大智慧分时均线公式


  H1:=MAX(DYNAINFO(3),DYNAINFO(5));

  L1:=MIN(DYNAINFO(3),DYNAINFO(6));

  P1:=H1-L1;

  阻力:L1+P1*7/8,COLOR00DD00,LAYER0;

  支撑:L1+P1*0.5/8,COLOR00DD00,LAYER0;

  cyc0:MAXCYC,colorff9900;

  PARTLINE(cyc0,cyc0》ref(cyc0,1.3)), COLORRED, LINETHICK4;

  PARTLINE(cyc0,cyc0《ref(cyc0,1.3)), ColorFF0000, LINETHICK4;

  tt:=BARSCOUNT(C);

  CC:=CLOSE;

  zz:=SUM(AMOUNT,tt)/SUM(VOL*100,tt);

  zz1:=BETWEEN(C/zz,1.05,0.95);

  均线:IF(zz1=0,MA(C,TT),zz),COLOR00FFFF,LINETHICK1;

  上均:均线 + AVEDEV(C,tt)*3,COLORFF00FF,LAYER0;

  下均:均线 - AVEDEV(C,tt)*3,COLORFF00FF,LAYER0;

  时长:=if(HOUR》=10 AND HOUR《15 ,1,0);{10点至 15点}

  均线:=IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),1.05,0.95)=0,MA(C,0), (SUM(AMOUNT,0)/SUM(VOL*100,0)));

  均线H:(均线*1.007 ),color000001;

  均线L:(均线/1.005 ),color000001;

  均线横盘:=C《均线H and C》均线L;

  量比:=sum(vol,0)*240/dynainfo(38)/barscount(c);

  量比5分钟:=sum(量比,5);

  量比10:=sum(量比,10);

  上个5分钟量比:=量比10-量比5分钟;

  放量:=sum(VOL,6)》REF(ma(VOL,30),1)*10;

  CC:CLOSE,COLORWHITE,LINETHICK2;

  MA30:=EMA(CLOSE,30);

  强弱界定:EMA(CLOSE,900);

  STICKLINE((MA30》强弱界定),MA30,强弱界定,1,0),Color0000FF;

  STICKLINE((MA30《强弱界定),MA30,强弱界定,1,0),Color00FF00;

  DRAWICON(CROSS(MA30,强弱界定),H,7),LAYER0;

  横盘:=((HHV(CLOSE,BARSCOUNT(CLOSE))-LLV(CLOSE,BARSCOUNT(CLOSE)))/CLOSE)& lt;1;

  横涨:量比5分钟》上个5分钟量比 and 横盘 and 时长 and 放量 and (CC》均线H) and DYNAINFO(22)《DYNAINFO(23),LINETHICK0;

  横跌:=横盘 and 时长 and 放量 and CROSS(均线L,CC) ;

  DRAWTEXT(CROSS(横涨,0),均线,‘’),COLORRED,LAYER0;

  突破:FILTER(横涨,100),LINETHICK0;

  下破:=FILTER(横跌,50);

  VERTLINE(突破,7),COLOR808080,LINETHICK1;

  VERTLINE(下破,7),COLOR808080,LINETHICK1;

  DRAWICON(CROSS(上均,阻力),阻力 -0.01,2),LAYER0,colorYELLOW,ALIGN1,VALIGN1,LINETHICK1;

  DRAWICON(CROSS(支撑,下均),支撑 -0.01,1),LAYER0,colorYELLOW,ALIGN1,VALIGN1,LINETHICK1;

  PARTLINE(c,c》=REF(c,1),RGB(255,0,0),c《=REF(c,1),RGB(0,255,0)),linethick3;

相关信息