大智慧艾略特波浪主图指标源码公式下载


  大智慧艾略特波浪主图指标源码公式下载

  N:=5;

  V1:=MA(HIGH,30)*1.15;

  V2:=MA(HIGH,3)*1.03;

  V3:=MA(LOW,3)*0.97;

  V4:=MA(LOW,30)*0.85;

  GET:ZIG(3,N),COLORaaaaaa;

  PL5:=ZIG(3,5);

  EN1:=ZIG(3,5)》REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)《=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)《=REF(ZIG(3,5),3);

  EX1:=ZIG(3,5)《REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)》=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)》=REF(ZIG(3,5),3);

  PL10:=ZIG(3,10);

  EN2:=ZIG(3,10)》REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)《=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)《=REF(ZIG(3,10),3);

  EX2:=ZIG(3,10)《REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)》=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)》=REF(ZIG(3,10),3);

  PL20:=ZIG(3,20);

  EN3:=ZIG(3,20)》REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)《=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)《=REF(ZIG(3,20),3);

  EX3:=ZIG(3,20)《REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)》=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)》=REF(ZIG(3,20),3);

  PL40:=ZIG(3,40);

  走强1:=BARSLAST(PL5《REF(PL5,1));

  走弱1:=BARSLAST(PL5》REF(PL5,1));

  走强2:=BARSLAST(PL10《REF(PL10,1));

  走弱2:=BARSLAST(PL10》REF(PL10,1));

  走强3:=BARSLAST(PL20《REF(PL20,1));

  走弱3:=BARSLAST(PL20》REF(PL20,1));

  ZTJZ5:=IF(PL10》REF(PL10,1),COUNT(EN1,走强2),0);

  ZTJD5:=IF(PL10》REF(PL10,1),COUNT(EX1,走强2),0);

  DTJZ5:=IF(PL10《REF(PL10,1),COUNT(EN1,走弱2),0);

  DTJD5:=IF(PL10《REF(PL10,1),COUNT(EX1,走弱2),0);

  ZTJZ10:=IF(PL20》REF(PL20,1),COUNT(EN2,走强3),0);

  ZTJD10:=IF(PL20》REF(PL20,1),COUNT(EX2,走强3),0);

  DTJZ10:=IF(PL20《REF(PL20,1),COUNT(EN2,走弱3),0);

  DTJD10:=IF(PL20《REF(PL20,1),COUNT(EX2,走弱3),0);

  DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,‘㈠’),COLORFFFF00;

  DRAWTEXT(EX1 AND DTJD5=2,H*1.02,‘㈡’),COLORFFFF00;

  DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,‘㈢’),COLORFFFF00;

  DRAWTEXT(EX1 AND PL10》REF(PL10,1) AND ZTJD5=1,H*1.02,‘⑴’),COLOR0000FF;

  DRAWTEXT(EN1 AND PL10》REF(PL10,1) AND ZTJZ5=2,L*0.98,‘⑵’),COLOR0000FF;

  DRAWTEXT(EX1 AND PL10》REF(PL10,1) AND ZTJZ5=2,H*1.02,‘⑶’),COLOR0000FF;

  DRAWTEXT(EN1 AND PL10》REF(PL10,1) AND ZTJZ5=3,L*0.98,‘⑷’),COLOR0000FF;

  DRAWTEXT(EX2 AND PL20》REF(PL20,1) AND ZTJD10=1,H*1.02,‘⑸’),COLOR0000FF;

  DRAWTEXT(EN2 AND DTJZ10=1,L*0.94,‘Ⅰ’),COLORFF6000;

  DRAWTEXT(EX2 AND DTJD10=2,H*1.06,‘Ⅱ’),COLORFF6000;

  DRAWTEXT(EN3 AND ZTJZ10=1,L*0.94,‘Ⅲ’),COLORFF6000;

  DRAWTEXT(EX2 AND PL20》REF(PL20,1) AND ZTJD10=1,H*1.06,‘①’),LINETHICK3,COLOR00FFFF;

  DRAWTEXT(EN2 AND PL20》REF(PL20,1) AND ZTJZ10=2,L*0.94,‘②’),LINETHICK3,COLOR00FFFF;

  DRAWTEXT(EX2 AND PL20》REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.06,‘③’),LINETHICK3,COLOR00FFFF;

  DRAWTEXT(EN2 AND PL20》REF(PL20,1) AND ZTJZ10=3,L*0.94,‘④’),LINETHICK3,COLOR00FFFF;

相关信息