大智慧∠45度角上升通道免费源码主图指标公式下载


  大智慧∠45度角上升通道免费源码主图指标公式下载

  DRAWGBK(c,‘mm2’),Color2B5516;

  a:=“[email=LTFunc5@FORLT2]LTFunc5@FORLT2[/email]”;

  s1:=“[email=LTFunc5@LT_S1]LTFunc5@LT_S1[/email]”;

  hs:=“[email=LTFunc5@LT_HS]LTFunc5@LT_HS[/email]”;

  ls:=“[email=LTFunc5@LT_LS]LTFunc5@LT_LS[/email]”; p1:=“[email=LTFunc5@LT_P1]LTFunc5@LT_P1[/email]”;

  upp:=“[email=LTFunc5@LT_UPP]LTFunc5@LT_UPP”;udd:=“LTFunc5@LT_UDD[/email]”;

  {hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};

  d1:=ema(abs(“ddx.ddx”),60); d2:=max(“ddx.ddx”/d1+7.5,7.5);

  d3:=min(“ddx.ddx”/d1,10); fb:=if(s1=0,hs,ls);

  tr0:=ifs(p1=1,‘明日收盘价《’+numtostrn(udd,2)+‘,出现S点\n’,‘若明日收盘价》’+numtostrn(upp,2)+‘,出现B点\n’);

  tr1:=ifs(s1=1,‘明日收盘价《’+numtostrn(ls,2)+‘,短线卖出机会’,‘若明日收盘价》’+numtostrn(hs,2)+‘短线买入机会’);

  tr2:=ifs(p1=1,ifs(cross(p1,0),‘B点’,‘持股’),ifs(cross(1,p1),‘S点’,‘持币’));

  tr3:=ifs(s1=0,‘向下,’,‘向上,’);

  tr4:=‘3.能量级别:’+numtostrn(d3,1)+‘级’;

  bs:=‘《*t=0092F7*》《*c=FFFFFF*》《*p=95*》’+datestr(date)+‘买卖点决 策系统提示\n’+‘《*t=E7FFFF*》《*c=000000*》《*p=95*》’+‘1.BS 点:’+tr2+‘,’+tr0+‘《*t=E7FFFF*》《*c=000000*》《*p=95*》’+‘2. 短线:’+tr3+tr1+‘\n’+‘《*t=E7FFFF*》《*c=000000*》《*p=95*》 ’+tr4;

  drawflagtext(1,fb,bs);

  STICKLINE(p1=1 and c》=o and o《》0,c,o,d2,0),color5454ff;

  STICKLINE(p1=1 and c》=o and o《》0,c,o,7.5,0),colorblack;

  STICKLINE(p1=1 and c》=o and o《》0,c,c,7.5,0),color5454ff;

  STICKLINE(p1=1 and c》=o and o《》0,o,o,7.5,0),color5454ff;

  STICKLINE(p1=1 and c》=o and o《》0,o,c,7.5,1),color5454ff;

  STICKLINE(p1=1 and c《=o,o,c,7.5,1),color5454ff;

  STICKLINE(p1=1 and c《=o,l,c,0.5,1),color5454ff;

  STICKLINE(p1=1 and c《=o,h,o,0.5,1),color5454ff;

  STICKLINE((p1《》1 or barscount(c)《3) and c》=o,c,o,7.5,1),colorffff54;

  STICKLINE((p1《》1 or barscount(c)《3) and c》=o,c,h,0.5,1),colorffff54;

  STICKLINE((p1《》1 or barscount(c)《3) and c》=o,l,o,0.5,1),colorffff54;

  drawbmp(p1=1 and ref(p1,1)=0,l,‘buy1.bmp’),align1,valign0;

  drawbmp(p1=0 and ref(p1,1)=1,h,‘sell1.bmp’),align1,valign2;

  drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))《》1,l,‘bs.bmp’),align1,valign0;

  drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))《》1,h,‘ss.bmp’),align1,valign2;

  JJ:=(CLOSE+HIGH+LOW)/3;

  A:=EMA(JJ,10);

  B:=REF(A,1);

  STICKLINE(A》B ,A ,B ,10 ,0 ),COLORYELLOW;

  STICKLINE(A《B ,B ,A ,10 ,0 ),COLORBLUE;

  MA1:MA(CLOSE,3),COLORYELLOW;

  MA2:MA(CLOSE,19),COLOR00ff00;

  xx1:=(C+L+H)/3;

  bbb13:=atan(ema(xx1,13)-ref(ema(xx1,13),1))*3.1416*10;

  ema8:=ema(c,8);

  DRAWTEXT(filter(bbb13》1 and ema(xx1,13)》ref(ema(xx1,8),1),10),

  ema8,‘∠45上升’),colorffffff;

  X1:POLYLINE(C《COST(50),COST(1)),COLOR008800;

  X3:POLYLINE(C《COST(50),COST(3)),COLOR008800;

  X5:POLYLINE(C《COST(50),COST(5)),COLOR008800;

  X7:POLYLINE(C《COST(50),COST(7)),COLOR008800;

  X9:POLYLINE(C《COST(50),COST(9)),COLOR008800;

  十:POLYLINE(C《COST(50),COST(10)),POINTDOT,COLOR008800;

  X11:POLYLINE(C《COST(50),COST(11)),COLOR66CC00;

  X31:POLYLINE(C《COST(50),COST(13)),COLOR66CC00;

  X51:POLYLINE(C《COST(50),COST(15)),COLOR66CC00;

  X71:POLYLINE(C《COST(50),COST(17)),COLOR66CC00;

  X91:POLYLINE(C《COST(50),COST(19)),COLOR66CC00;

  二十:POLYLINE(C《COST(50),COST(20)),POINTDOT,COLOR66CC00;

  X12:POLYLINE(C《COST(50),COST(21)),COLORFF9933;

  X32:POLYLINE(C《COST(50),COST(23)),COLORFF9933;

  X52:POLYLINE(C《COST(50),COST(25)),COLORFF9933;

  X72:POLYLINE(C《COST(50),COST(27)),COLORFF9933;

  X92:POLYLINE(C《COST(50),COST(29)),COLORFF9933;

  三十:POLYLINE(C《COST(50),COST(30)),POINTDOT,COLORFF9933;

  X13:POLYLINE(C《COST(50),COST(31)),COLOR008800;

  X33:POLYLINE(C《COST(50),COST(33)),COLOR008800;

  X53:POLYLINE(C《COST(50),COST(35)),COLOR008800;

  X73:POLYLINE(C《COST(50),COST(37)),COLOR008800;

  X93:POLYLINE(C《COST(50),COST(39)),COLOR008800;

  四十:POLYLINE(C《COST(50),COST(40)),POINTDOT,COLOR008800;

  X14:POLYLINE(C》0,COST(41)),COLOR33CC00;

  X34:POLYLINE(C》0,COST(43)),COLOR33CC00;

  X54:POLYLINE(C》0,COST(45)),COLOR33CC00;

  X74:POLYLINE(C》0,COST(47)),COLOR33CC00;

  X94:POLYLINE(C》0,COST(49)),COLOR33CC00;

  COST(50),COLORYELLOW,CIRCLEDOT;

  STICKLINE(C》=O,C,O,9,1),COLORRED;

  STICKLINE(C》=O,L,O,0.1,0),COLORRED;

  STICKLINE(C》=O,C,H,0.1,0),COLORRED;

  STICKLINE(C《O,C,O,9,0),COLORFFFF00;

  STICKLINE(C《O,H,L,0.1,0),COLORFFFF00;

  rcc:=DYNAINFO(3);

  s2:=sma(c,3,1);

  s6:=sma(c,5,1);

  dk:=2*(s2-s6);

  STICKLINE(dk》0,rcc,rcc+dk,0,1),COLORRED;

  STICKLINE(dk《0,rcc,rcc+dk,0,1),COLORCYAN;

  流通盘大小:=FINANCE2(37)/1000000*100;

  DRAWTEXTABS(2,20,‘总股本:’+NUMTOSTR(FINANCE2(35)/10000 )+‘亿’+‘ 流通股:’+ NUMTOSTR(CAPITAL/1000000)+‘亿’),COLORGREEN

  ;DRAWTEXTABS(2,35,‘上市日期:’+STR(FINANCE2(2))+‘日’),COLOR0000FF;

  每股收益:=FINANCE2(3);

  每股市盈率:=DYNAINFO(39);

  每股净资产:=FINANCE2(4);

  销售毛利率:=FINANCE2(12);

  主营收入同比:=FINANCE2(11);

  净利润同比增长:=FINANCE2(10);

  每股公积金:=FINANCE2(7);

  每股未分配:=FINANCE2(8);

  {DRAWTEXTABS(2,40,‘基本面优劣提示:’),COLOR505050;}

  DRAWTEXTABS(2,50,‘每股收益:’+NUMTOSTRN(每股收益,2)+‘元’),COLORF00FF0;

  DRAWTEXTABS(2,65,‘每股市盈率:’+NUMTOSTRN(每股市盈率,1)+‘倍’),COLORGREEN;

  DRAWTEXTABS(2,80,‘每股净资产:’+NUMTOSTRN(每股净资产,2)+‘元’),Color1880FF;

  DRAWTEXTABS(2,95,‘每股公积金:’+NUMTOSTRN(每股公积金,2)+‘元’),COLORYELLOW;

  DRAWTEXTABS(2,110,‘每股未分配:’+NUMTOSTRN(每股未分配,2)+‘元’),COLORF00FF0;

  DRAWTEXTABS(2,125,‘销售毛利率:’+NUMTOSTRN(销售毛利率,2)+‘%’),COLORGREEN;

  DRAWTEXTABS(2,140,‘主营收入同比增长:’+NUMTOSTRN(主营收入同比,2)+‘%’),COLOR0000FF;

  DRAWTEXTABS(2,155,‘净利润同比增长:’+NUMTOSTRN(净利润同比增长,2)+‘%’),COLORYELLOW;

  DRAWTEXTABS(5,5,‘1’),linethick1,COLOR00EEff;

  {DRAWTEXTABS(2,80,‘换手率高低提示:’),COLOR505050;}

  DRAWTEXTABS(2,5,‘所属板块:’+BKNAME),COLORYELLOW;

  DRAWTEXTREL(380,20,STKLABEL+‘ ’+STKNAME+‘ ’+DYNAINFO(7)+‘元’+‘ ’+DYNAINFO(14)*100+‘%’),COLORFFFF00,LINETHICK4;

  DRAWTEXTREL(400,255,‘■主题库:’+SELFSTRING(‘主题投资库’)),COLORF00FF0;

  DRAWTEXTREL(400,210,‘■千股点评:’+SELFSTRING(‘千股千评’)),Color119FFF;

  DRAWTEXTREL(720,75,‘■星级:’+SelfString(‘星级’)),colorRED;

  DRAWTEXTREL(800,75,‘■星级值:’+SelfString(‘星级值’)),COLOR00FFFF;

  DRAWTEXTREL(870,75,‘■评级:’+SelfString(‘评级’)),color00ff00;

  DRAWTEXTREL(400,255,‘■主题库:’+SELFSTRING(‘主题投资库’)),COLORF00FF0;

  DRAWTEXTREL(400,120,‘■大盘指数:’+INDEXC),COLORF00FF0;

  DRAWTEXTREL(550,120,‘■大盘涨幅:’+((INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100)+‘%’),LINETHICK0,PRECIS2,Color119FFF;

  DRAWTEXTREL(650,120,‘■大盘涨跌:’+INDEXC-REF(INDEXC,1)),LINETHICK0,PRECIS2,COLORFFFF00;

  DRAWTEXTREL(400,165,‘■上涨家数:’+NUMTOSTRN(DYNAINFO(66),0)+‘家’),COLOR0000FF;

  DRAWTEXTREL(550,165,‘■下跌家数:’+NUMTOSTRN(DYNAINFO(67),0)+‘家’),COLOR00FF00;

  DRAWTEXTREL(650,165,‘■平盘家数:’+NUMTOSTRN(DYNAINFO(68),0)+‘家’),COLORFFFFFF;

  DRAWTEXTREL(400,75,‘今 日 换 手 率:’+ DYNAINFO(37)*100+‘%’),COLORYELLOW;

  gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);

  明日阻力:=l+(gj-l)+(c-l);

  明日支撑:=l+(c-gj);

  今日阻力:=REF(明日阻力 , 1);

  今日支撑:=REF(明日支撑 , 1);

  STICKLINE(DISPSTATUS=2 and c》=今日阻力,今日阻力,今日阻力,20,0),Color0000FF;

  STICKLINE(DISPSTATUS=2 and c《今日阻力,今日阻力,今日阻力,20,0),Color00FF00;

  STICKLINE(DISPSTATUS=2 and c》=今日支撑,今日支撑,今日支撑,20,0),ColorFF00FF;

  STICKLINE(DISPSTATUS=2 and c《今日支撑,今日支撑,今日支撑,20,0),ColorFF9900;

  DRAWTEXTREL(650,75,‘今日支撑:’+NUMTOSTRN(今日支撑 ,2 )),Color119FFF;

  DRAWTEXTREL(550,75,‘今日阻力:’+NUMTOSTRN(今日阻力 ,2 )),ColorGREEN;

  DRAWTEXTREL(620,20,‘今日涨跌:’+C-REF(C,1)+‘元’),LINETHICK4,COLORFFFF00;

相关信息